p PatchFirst

CVE-2026-42245

CVE-2026-42245 · net-imap: Quadratic complexity when reading response literals

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Net::IMAP implements Internet Message Access Protocol (IMAP) client functionality in Ruby. Prior to versions 0.4.24, 0.5.14, and 0.6.4, Net::IMAP::ResponseReader has quadratic time complexity when reading large responses containing many string literals. A hostile server can send responses which are crafted to exhaust the client's CPU for a denial of service attack. This issue has been patched in versions 0.4.24, 0.5.14, and 0.6.4.

CVSS 2.3 · Baja · EPSS 0,4%

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • net-imap

    Versiones
    • < 0.4.24: Afectada
    • >= 0.5.0, < 0.5.14: Afectada
    • >= 0.6.0, < 0.6.4: Afectada

    Sin corrección publicada

  • ruby3.1 Debian:12

    Versiones
    • 3.1.2-7
    • 3.1.2-7+deb12u1
    • 3.1.2-7+hurd.1
    • 3.1.2-8
    • 3.1.2-8.1~exp1
    • 3.1.2-8.3
    • 3.1.2-8.4
    • 3.1.2-8.5
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • ruby3.3 Debian:13

    Versiones
    • 3.3.8-2
    • 3.3.8-2.1
    • 3.3.8-2.2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • ruby3.3 Debian:14

    Versiones
    • 3.3.8-2
    • 3.3.8-2.1
    • 3.3.8-2.2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • jruby Ubuntu:25.10

    Versiones
    • 9.4.8.0+ds-2ubuntu1
    • 9.4.8.0+ds-3ubuntu1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • ruby3.3 Ubuntu:25.10

    Versiones
    • 3.3.7-1ubuntu2
    • 3.3.8-2ubuntu1
    • 3.3.8-2ubuntu2
    • 3.3.8-2ubuntu2.1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • jruby Ubuntu:26.10

    Versiones
    • 9.4.8.0+ds-3ubuntu1
    • 9.4.14.0+ds-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • ruby3.3 Ubuntu:26.10

    Versiones
    • 3.3.8-2ubuntu3
    • 3.3.8-2.2ubuntu4
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →