CVE-2026-42258
CVE-2026-42258 · net-imap: Command Injection via unvalidated Symbol inputs
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Esta página muestra una selección de datos de las fuentes. Consulte los avisos enlazados para ver la descripción completa y las versiones afectadas.
Net::IMAP implements Internet Message Access Protocol (IMAP) client functionality in Ruby. Prior to versions 0.4.24, 0.5.14, and 0.6.4, symbol arguments to commands are vulnerable to a CRLF Injection / IMAP Command injection via Symbol arguments passed to IMAP commands. This issue has been patched in versions 0.4.24, 0.5.14, and 0.6.4.
CVSS 5.8 · Media · EPSS 0,8% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
net-imap
- Versiones
- < 0.4.24: Afectada
- >= 0.5.0, < 0.5.14: Afectada
- >= 0.6.0, < 0.6.4: Afectada
Sin corrección publicada
ruby3.1 Debian:12
- Versiones
- 3.1.2-7
- 3.1.2-7+deb12u1
- 3.1.2-7+hurd.1
- 3.1.2-8
- 3.1.2-8.1~exp1
- 3.1.2-8.3
- 3.1.2-8.4
- 3.1.2-8.5
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
ruby3.3 Debian:13
- Versiones
- 3.3.8-2
- 3.3.8-2.1
- 3.3.8-2.2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
ruby3.3 Debian:14
- Versiones
- 3.3.8-2
- 3.3.8-2.1
- 3.3.8-2.2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
jruby Ubuntu:Pro:14.04:LTS
- Versiones
- 1.5.6-5ubuntu1
- 1.5.6-6
- 1.5.6-7
- 1.5.6-9+deb8u2build0.14.04.1~esm2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
ruby2.3 Ubuntu:Pro:16.04:LTS
- Versiones
- 2.3.0-1
- 2.3.0-2
- 2.3.0-4ubuntu2
- 2.3.0-4ubuntu3
- 2.3.0-5ubuntu1
- 2.3.1-2~16.04
- 2.3.1-2~16.04.2
- 2.3.1-2~16.04.4
- 2.3.1-2~16.04.5
- 2.3.1-2~16.04.6
- 2.3.1-2~16.04.7
- 2.3.1-2~16.04.9
- 2.3.1-2~16.04.10
- 2.3.1-2~16.04.11
- 2.3.1-2~16.04.12
- 2.3.1-2~ubuntu16.04.13
- 2.3.1-2~ubuntu16.04.14
- 2.3.1-2~ubuntu16.04.15
- 2.3.1-2~ubuntu16.04.16
- 2.3.1-2~ubuntu16.04.16+esm1
- 2.3.1-2~ubuntu16.04.16+esm2
- 2.3.1-2~ubuntu16.04.16+esm3
- 2.3.1-2~ubuntu16.04.16+esm4
- 2.3.1-2~ubuntu16.04.16+esm5
- 2.3.1-2~ubuntu16.04.16+esm6
- 2.3.1-2~ubuntu16.04.16+esm7
- 2.3.1-2~ubuntu16.04.16+esm8
- 2.3.1-2~ubuntu16.04.16+esm9
- 2.3.1-2~ubuntu16.04.16+esm10
- 2.3.1-2~ubuntu16.04.16+esm11
- 2.3.1-2~ubuntu16.04.16+esm12
- 2.3.1-2~ubuntu16.04.16+esm14
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.3.1-2~ubuntu16.04.16+esm15
Actualiza a 2.3.1-2~ubuntu16.04.16+esm15
jruby Ubuntu:16.04:LTS
- Versiones
- 1.7.21-2ubuntu4
- 1.7.22-1ubuntu1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
ruby2.5 Ubuntu:Pro:18.04:LTS
- Versiones
- 2.5.0~preview1-1ubuntu2
- 2.5.0-4ubuntu1
- 2.5.0-4ubuntu4
- 2.5.0-5ubuntu1
- 2.5.0-6ubuntu1
- 2.5.1-1ubuntu1
- 2.5.1-1ubuntu1.1
- 2.5.1-1ubuntu1.2
- 2.5.1-1ubuntu1.4
- 2.5.1-1ubuntu1.5
- 2.5.1-1ubuntu1.6
- 2.5.1-1ubuntu1.7
- 2.5.1-1ubuntu1.8
- 2.5.1-1ubuntu1.9
- 2.5.1-1ubuntu1.10
- 2.5.1-1ubuntu1.11
- 2.5.1-1ubuntu1.12
- 2.5.1-1ubuntu1.13
- 2.5.1-1ubuntu1.14
- 2.5.1-1ubuntu1.15
- 2.5.1-1ubuntu1.16
- 2.5.1-1ubuntu1.16+esm1
- 2.5.1-1ubuntu1.16+esm3
- 2.5.1-1ubuntu1.16+esm4
- 2.5.1-1ubuntu1.16+esm5
- 2.5.1-1ubuntu1.16+esm6
- 2.5.1-1ubuntu1.16+esm7
- 2.5.1-1ubuntu1.16+esm8
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
jruby Ubuntu:18.04:LTS
- Versiones
- 9.1.13.0-1
- 9.1.17.0-1~18.04
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
ruby2.7 Ubuntu:Pro:20.04:LTS
- Versiones
- 2.7.0-1
- 2.7.0-2
- 2.7.0-3
- 2.7.0-4
- 2.7.0-4ubuntu1
- 2.7.0-5ubuntu1
- 2.7.0-5ubuntu1.1
- 2.7.0-5ubuntu1.2
- 2.7.0-5ubuntu1.3
- 2.7.0-5ubuntu1.4
- 2.7.0-5ubuntu1.5
- 2.7.0-5ubuntu1.6
- 2.7.0-5ubuntu1.7
- 2.7.0-5ubuntu1.8
- 2.7.0-5ubuntu1.9
- 2.7.0-5ubuntu1.10
- 2.7.0-5ubuntu1.11
- 2.7.0-5ubuntu1.12
- 2.7.0-5ubuntu1.13
- 2.7.0-5ubuntu1.14
- 2.7.0-5ubuntu1.15
- 2.7.0-5ubuntu1.16
- 2.7.0-5ubuntu1.17
- 2.7.0-5ubuntu1.18
- 2.7.0-5ubuntu1.18+esm1
- 2.7.0-5ubuntu1.18+esm3
- 2.7.0-5ubuntu1.18+esm4
- 2.7.0-5ubuntu1.18+esm5
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
jruby Ubuntu:20.04:LTS
- Versiones
- 9.1.17.0-3
- 9.1.17.0-3build5
- 9.1.17.0-3build6
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
ruby3.0 Ubuntu:22.04:LTS
- Versiones
- 3.0.2-5ubuntu1
- 3.0.2-7
- 3.0.2-7ubuntu2
- 3.0.2-7ubuntu2.1
- 3.0.2-7ubuntu2.2
- 3.0.2-7ubuntu2.3
- 3.0.2-7ubuntu2.4
- 3.0.2-7ubuntu2.5
- 3.0.2-7ubuntu2.6
- 3.0.2-7ubuntu2.7
- 3.0.2-7ubuntu2.8
- 3.0.2-7ubuntu2.10
- 3.0.2-7ubuntu2.11
- 3.0.2-7ubuntu2.12
- 3.0.2-7ubuntu2.13
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
jruby Ubuntu:24.04:LTS
- Versiones
- 9.3.9.0+ds-1
- 9.4.5.0+ds-1
- 9.4.5.0+ds-1ubuntu1
- 9.4.6.0+ds-1ubuntu3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
ruby3.2 Ubuntu:24.04:LTS
- Versiones
- 3.2.3-1
- 3.2.3-1build2
- 3.2.3-1build3
- 3.2.3-1ubuntu0.24.04.1
- 3.2.3-1ubuntu0.24.04.3
- 3.2.3-1ubuntu0.24.04.5
- 3.2.3-1ubuntu0.24.04.6
- 3.2.3-1ubuntu0.24.04.7
- 3.2.3-1ubuntu0.24.04.8
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
jruby Ubuntu:25.10
- Versiones
- 9.4.8.0+ds-2ubuntu1
- 9.4.8.0+ds-3ubuntu1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
ruby3.3 Ubuntu:25.10
- Versiones
- 3.3.7-1ubuntu2
- 3.3.8-2ubuntu1
- 3.3.8-2ubuntu2
- 3.3.8-2ubuntu2.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
jruby Ubuntu:26.10
- Versiones
- 9.4.8.0+ds-3ubuntu1
- 9.4.14.0+ds-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
ruby3.3 Ubuntu:26.10
- Versiones
- 3.3.8-2ubuntu3
- 3.3.8-2.2ubuntu4
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
jruby Ubuntu:26.04:LTS
- Versiones
- 9.4.8.0+ds-3ubuntu1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
ruby3.3 Ubuntu:26.04:LTS
- Versiones
- 3.3.8-2ubuntu2
- 3.3.8-2ubuntu3
- 3.3.8-2ubuntu3.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/ruby/net-imap/security/advisories/GHSA-75xq-5h9v-w6px
- https://github.com/ruby/net-imap/releases/tag/v0.4.24
- https://github.com/ruby/net-imap/releases/tag/v0.5.14
- https://github.com/ruby/net-imap/releases/tag/v0.6.4
- https://access.redhat.com/security/cve/CVE-2026-42258
- https://bugzilla.redhat.com/show_bug.cgi?id=2468498
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-42258.json
- https://access.redhat.com/errata/RHSA-2026:37397
- https://access.redhat.com/errata/RHSA-2026:35895
- https://access.redhat.com/errata/RHSA-2026:33565
- https://access.redhat.com/errata/RHSA-2026:33540
- https://access.redhat.com/errata/RHSA-2026:33514
- https://access.redhat.com/errata/RHSA-2026:33515
- https://access.redhat.com/errata/RHSA-2026:35866
- https://access.redhat.com/errata/RHSA-2026:35867
- https://access.redhat.com/errata/RHSA-2026:34076
- https://access.redhat.com/errata/RHSA-2026:35834
- https://access.redhat.com/errata/RHSA-2026:33630
- https://access.redhat.com/errata/RHSA-2026:36099
- https://access.redhat.com/errata/RHSA-2026:33462
- https://access.redhat.com/errata/RHSA-2026:37238
- https://access.redhat.com/errata/RHSA-2026:33512
- https://access.redhat.com/errata/RHSA-2026:33576
- https://nvd.nist.gov/vuln/detail/CVE-2026-42258