CVE-2026-42264
CVE-2026-42264 · Axios: Prototype pollution read-side gadgets in HTTP adapter allow credential injection and request hijacking
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Axios is a promise based HTTP client for the browser and Node.js. From version 1.0.0 to before version 1.15.2, fFive config properties (auth, baseURL, socketPath, beforeRedirect, and insecureHTTPParser) in the HTTP adapter are read via direct property access without hasOwnProperty guards, making them exploitable as prototype pollution gadgets. When Object.prototype is polluted by another dependency in the same process, axios silently picks up these polluted values on every outbound HTTP request. This issue has been patched in version 1.15.2.
CVSS 7.4 · Alta · EPSS 0,8% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · node
Productos y versiones afectados
axios
- Versiones
- >= 1.0.0, < 1.15.2: Afectada
Sin corrección publicada
node-axios Debian:12
- Versiones
- 1.11.0+dfsg-1
- 1.12.1+dfsg-1
- 1.13.1+dfsg-1
- 1.13.2+dfsg-1
- 1.14.0+dfsg-1
- 1.15.0-1
- 1.15.2-1
- 1.16.0-1
- 1.18.0-1
- 1.19.0-1
- 1.2.1+dfsg-1
- 1.2.1+dfsg-1+deb12u1
- 1.20.0-1
- 1.5.1+dfsg-1
- 1.6.2+dfsg-1
- 1.6.8+dfsg-1
- 1.6.8+dfsg-2
- 1.7.3+dfsg-1
- 1.7.4+dfsg-1
- 1.7.7+dfsg-1
- 1.7.9+dfsg-1
- 1.8.4+dfsg-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-axios Debian:13
- Versiones
- 1.11.0+dfsg-1
- 1.12.1+dfsg-1
- 1.13.1+dfsg-1
- 1.13.2+dfsg-1
- 1.14.0+dfsg-1
- 1.15.0-1
- 1.15.2-1
- 1.16.0-1
- 1.18.0-1
- 1.19.0-1
- 1.20.0-1
- 1.8.4+dfsg-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-axios Debian:14
- Versiones
- 1.11.0+dfsg-1
- 1.12.1+dfsg-1
- 1.13.1+dfsg-1
- 1.13.2+dfsg-1
- 1.14.0+dfsg-1
- 1.15.0-1
- 1.8.4+dfsg-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.15.2-1
Actualiza a 1.15.2-1
axios npm
- Intervalos de versiones afectados
- SEMVER: ≥ 1.0.0, < 1.15.2
Actualiza a 1.15.2
node-axios Ubuntu:Pro:24.04:LTS
- Versiones
- 1.2.1+dfsg-1
- 1.5.1+dfsg-1
- 1.6.2+dfsg-1
- 1.6.8+dfsg-2
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.6.8+dfsg-2ubuntu0.1~esm1
Actualiza a 1.6.8+dfsg-2ubuntu0.1~esm1
node-axios Ubuntu:25.10
- Versiones
- 1.7.9+dfsg-1
- 1.8.4+dfsg-1
- 1.11.0+dfsg-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-axios Ubuntu:Pro:26.04:LTS
- Versiones
- 1.11.0+dfsg-1
- 1.12.1+dfsg-1
- 1.13.2+dfsg-1build1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.13.2+dfsg-1ubuntu0.1~esm1
Actualiza a 1.13.2+dfsg-1ubuntu0.1~esm1
Fuentes originales
- https://github.com/axios/axios/security/advisories/GHSA-q8qp-cvcw-x6jj
- https://github.com/axios/axios/pull/10779
- https://github.com/axios/axios/commit/47915144662f2733e6c051bdcb895a8c8f0586aa
- https://github.com/axios/axios/releases/tag/v1.15.2
- https://access.redhat.com/security/cve/CVE-2026-42264
- https://bugzilla.redhat.com/show_bug.cgi?id=2467927
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-42264.json
- https://access.redhat.com/errata/RHSA-2026:66545
- https://access.redhat.com/errata/RHSA-2026:66488
- https://access.redhat.com/errata/RHSA-2026:20938
- https://access.redhat.com/errata/RHSA-2026:20889
- https://access.redhat.com/errata/RHSA-2026:36207
- https://access.redhat.com/errata/RHSA-2026:42142
- https://access.redhat.com/errata/RHSA-2026:41951
- https://access.redhat.com/errata/RHSA-2026:41928
- https://access.redhat.com/errata/RHSA-2026:50300
- https://access.redhat.com/errata/RHSA-2026:60520
- https://access.redhat.com/errata/RHSA-2026:62260
- https://access.redhat.com/errata/RHSA-2026:37287
- https://access.redhat.com/errata/RHSA-2026:37297
- https://access.redhat.com/errata/RHSA-2026:33173
- https://access.redhat.com/errata/RHSA-2026:37288
- https://nvd.nist.gov/vuln/detail/CVE-2026-42264