CVE-2026-42767
CVE-2026-42767 · NULL Pointer Dereference in CRMF EncryptedValue Decryption
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Issue summary: An attacker-controlled CMP (Certificate Management Protocol) server could trigger a NULL pointer dereference in a CMP client application. Impact summary: A NULL pointer dereference causes a crash of the application and a Denial of Service. An attacker controlling a CMP server (or acting as a man-in-the-middle) could craft a CMP response containing a CRMF (Certificate Request Message Format) CertRepMessage with an EncryptedValue structure where the symmAlg field has an algorithm OID but no parameters field. When the OpenSSL CMP client processes this response, the NULL dereference occurs, causing a crash of the CMP client. Applications that process untrusted CMP/CRMF messages may be affected. The FIPS modules in 4.0, 3.6, 3.5, 3.4, and 3.0 are not affected by this issue, as the affected code is outside the OpenSSL FIPS module boundary.
CVSS 5.9 · Media · EPSS 0,6% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · network
Productos y versiones afectados
openssl
- Versiones
- ≥ 4.0.0, < 4.0.1: Afectada (semver)
- ≥ 3.6.0, < 3.6.3: Afectada (semver)
- ≥ 3.5.0, < 3.5.7: Afectada (semver)
- ≥ 3.4.0, < 3.4.6: Afectada (semver)
- ≥ 3.0.0, < 3.0.21: Afectada (semver)
Actualiza a 3.0.21; Actualiza a 3.4.6; Actualiza a 3.5.7; Actualiza a 3.6.3; Actualiza a 4.0.1
openssl Debian:12
- Versiones
- 3.0.10-1
- 3.0.10-1~deb12u1
- 3.0.11-1
- 3.0.11-1~deb12u1
- 3.0.11-1~deb12u2
- 3.0.12-1
- 3.0.12-2
- 3.0.13-1~deb12u1
- 3.0.13-1~deb12u2
- 3.0.14-1~deb12u1
- 3.0.14-1~deb12u2
- 3.0.15-1~deb12u1
- 3.0.16-1~deb12u1
- 3.0.17-1~deb12u1
- 3.0.17-1~deb12u2
- 3.0.17-1~deb12u3
- 3.0.18-1~deb12u1
- 3.0.18-1~deb12u2
- 3.0.19-1~deb12u1
- 3.0.19-1~deb12u2
- 3.0.20-1~deb12u1
- 3.0.20-1~deb12u2
- 3.0.9-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.0.22-1~deb12u1
Actualiza a 3.0.22-1~deb12u1
openssl Debian:13
- Versiones
- 3.5.1-1
- 3.5.1-1+deb13u1
- 3.5.2-1
- 3.5.3-1
- 3.5.4-1
- 3.5.4-1~deb13u1
- 3.5.4-1~deb13u2
- 3.5.5-1
- 3.5.5-1~deb13u1
- 3.5.5-1~deb13u2
- 3.5.6-1~deb13u1
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.5.6-1~deb13u2
Actualiza a 3.5.6-1~deb13u2
openssl Debian:14
- Versiones
- 3.5.1-1
- 3.5.2-1
- 3.5.3-1
- 3.5.4-1
- 3.5.4-1~deb13u1
- 3.5.4-1~deb13u2
- 3.5.5-1
- 3.5.5-1~deb13u1
- 3.5.5-1~deb13u2
- 3.5.6-1~deb13u1
- 3.5.6-1~deb13u2
- 3.5.7-1~deb13u1
- 3.5.7-1~deb13u2
- 3.5.7-1~deb13u3
- 3.6.0-1
- 3.6.0-2
- 3.6.0~~alpha1-1
- 3.6.0~~beta1-1
- 3.6.1-1
- 3.6.1-2
- 3.6.1-3
- 3.6.2-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.6.3-1
Actualiza a 3.6.3-1
openssl Ubuntu:22.04:LTS
- Versiones
- 1.1.1l-1ubuntu1
- 3.0.0-1ubuntu1
- 3.0.1-0ubuntu1
- 3.0.2-0ubuntu1
- 3.0.2-0ubuntu1.1
- 3.0.2-0ubuntu1.2
- 3.0.2-0ubuntu1.4
- 3.0.2-0ubuntu1.5
- 3.0.2-0ubuntu1.6
- 3.0.2-0ubuntu1.7
- 3.0.2-0ubuntu1.8
- 3.0.2-0ubuntu1.9
- 3.0.2-0ubuntu1.10
- 3.0.2-0ubuntu1.12
- 3.0.2-0ubuntu1.13
- 3.0.2-0ubuntu1.14
- 3.0.2-0ubuntu1.15
- 3.0.2-0ubuntu1.16
- 3.0.2-0ubuntu1.17
- 3.0.2-0ubuntu1.18
- 3.0.2-0ubuntu1.19
- 3.0.2-0ubuntu1.20
- 3.0.2-0ubuntu1.21
- 3.0.2-0ubuntu1.23
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.0.2-0ubuntu1.25
Actualiza a 3.0.2-0ubuntu1.25
nodejs Ubuntu:Pro:22.04:LTS
- Versiones
- 12.22.5~dfsg-5ubuntu1
- 12.22.7~dfsg-2ubuntu1
- 12.22.7~dfsg-2ubuntu3
- 12.22.9~dfsg-1ubuntu2
- 12.22.9~dfsg-1ubuntu3
- 12.22.9~dfsg-1ubuntu3.1
- 12.22.9~dfsg-1ubuntu3.2
- 12.22.9~dfsg-1ubuntu3.3
- 12.22.9~dfsg-1ubuntu3.4
- 12.22.9~dfsg-1ubuntu3.5
- 12.22.9~dfsg-1ubuntu3.6
- 12.22.9~dfsg-1ubuntu3.6+esm2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
openssl Ubuntu:Pro:FIPS-preview:22.04:LTS
- Versiones
- 3.0.2-0ubuntu1.10+Fips1
- 3.0.2-0ubuntu1.12+Fips1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
openssl-fips Ubuntu:Pro:FIPS-preview:22.04:LTS
- Versiones
- 3.0.5-0ubuntu0.1+Fips2.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
openssl Ubuntu:Pro:FIPS-updates:22.04:LTS
- Versiones
- 3.0.2-0ubuntu1.10+Fips1
- 3.0.2-0ubuntu1.12+Fips1
- 3.0.2-0ubuntu1.14+Fips1
- 3.0.2-0ubuntu1.15+Fips1
- 3.0.2-0ubuntu1.16+Fips1
- 3.0.2-0ubuntu1.17+Fips1
- 3.0.2-0ubuntu1.18+Fips1
- 3.0.2-0ubuntu1.19+Fips1
- 3.0.2-0ubuntu1.20+Fips1
- 3.0.2-0ubuntu1.21+Fips1
- 3.0.2-0ubuntu1.23+Fips1
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.0.2-0ubuntu1.25+Fips1
Actualiza a 3.0.2-0ubuntu1.25+Fips1
openssl-fips Ubuntu:Pro:FIPS-updates:22.04:LTS
- Versiones
- 3.0.5-0ubuntu0.1+Fips2.1
- 3.0.5-0ubuntu0.2+Fips1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
edk2 Ubuntu:24.04:LTS
- Versiones
- 2023.05-2
- 2023.11-2
- 2023.11-3
- 2023.11-4
- 2023.11-5
- 2023.11-6
- 2023.11-8
- 2024.02-1
- 2024.02-2
- 2024.02-2ubuntu0.1
- 2024.02-2ubuntu0.3
- 2024.02-2ubuntu0.4
- 2024.02-2ubuntu0.5
- 2024.02-2ubuntu0.6
- 2024.02-2ubuntu0.7
- 2024.02-2ubuntu0.8
- 2024.02-2ubuntu0.9
- 2024.02-2ubuntu0.10
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
openssl Ubuntu:24.04:LTS
- Versiones
- 3.0.10-1ubuntu2
- 3.0.10-1ubuntu2.1
- 3.0.10-1ubuntu3
- 3.0.10-1ubuntu4
- 3.0.13-0ubuntu2
- 3.0.13-0ubuntu3
- 3.0.13-0ubuntu3.1
- 3.0.13-0ubuntu3.2
- 3.0.13-0ubuntu3.3
- 3.0.13-0ubuntu3.4
- 3.0.13-0ubuntu3.5
- 3.0.13-0ubuntu3.6
- 3.0.13-0ubuntu3.7
- 3.0.13-0ubuntu3.9
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.0.13-0ubuntu3.11
Actualiza a 3.0.13-0ubuntu3.11
openssl-fips Ubuntu:Pro:FIPS-updates:24.04:LTS
- Versiones
- 3.0.13-0ubuntu3+Fips1
- 3.0.13-0ubuntu3.6+Fips1
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.0.13-0ubuntu3.12+Fips1
Actualiza a 3.0.13-0ubuntu3.12+Fips1
edk2 Ubuntu:25.10
- Versiones
- 2025.02-3ubuntu2
- 2025.02-8
- 2025.02-8ubuntu1
- 2025.02-8ubuntu2
- 2025.02-8ubuntu3
- 2025.02-8ubuntu3.1
- 2025.02-8ubuntu3.2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
openssl Ubuntu:25.10
- Versiones
- 3.4.1-1ubuntu3
- 3.5.0-2ubuntu1
- 3.5.2-1ubuntu1
- 3.5.3-1ubuntu2
- 3.5.3-1ubuntu3
- 3.5.3-1ubuntu3.3
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.5.3-1ubuntu3.4
Actualiza a 3.5.3-1ubuntu3.4
edk2 Ubuntu:26.10
- Versiones
- 2025.11-3ubuntu7
- 2025.11-3ubuntu8
- 2026.05-2ubuntu1
- 2026.05-2ubuntu2
- 2026.05-2ubuntu3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
edk2-hwe Ubuntu:26.10
- Versiones
- 2025.11-3ubuntu8
- 2025.11-3ubuntu9
- 2026.05-2ubuntu1
- 2026.05-2ubuntu2
- 2026.05-2ubuntu3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
edk2 Ubuntu:26.04:LTS
- Versiones
- 2025.02-8ubuntu3
- 2025.11-3ubuntu6
- 2025.11-3ubuntu7
- 2025.11-3ubuntu7.2
- 2025.11-3ubuntu7.3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
edk2-hwe Ubuntu:26.04:LTS
- Versiones
- 2025.11-3ubuntu6
- 2025.11-3ubuntu8
- 2025.11-3ubuntu8.2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
openssl Ubuntu:26.04:LTS
- Versiones
- 3.5.3-1ubuntu2
- 3.5.5-1ubuntu1
- 3.5.5-1ubuntu3
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.5.5-1ubuntu3.2
Actualiza a 3.5.5-1ubuntu3.2
Fuentes originales
- https://openssl-library.org/news/secadv/20260609.txt
- https://github.com/openssl/openssl/commit/b90ff3b1bd33b1c18e6a09936d097c2eddef8873
- https://github.com/openssl/openssl/commit/e6f912907fc2ec82a0fd07aae55172c5e5e3d90d
- https://github.com/openssl/openssl/commit/810b722f772652ad48042bcc7ab07e3414b11d0f
- https://github.com/openssl/openssl/commit/665d5254083affde9982efca7c41dd01cacc8774
- https://github.com/openssl/openssl/commit/61a86a8cd73546c9fea916f3d304c1293e05c046
- https://nvd.nist.gov/vuln/detail/CVE-2026-42767