p PatchFirst

CVE-2026-44019

CVE-2026-44019 · Docling Core has insufficient validation of image reference URIs

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Docling Core defines core data types and transformations for the document processing application Docling. In versions 2.5.0 and above, prior to 2.74.1, docling-core could allow local file:// image references and accepted inline data: content without a decoded-size limit. In applications that accept untrusted image references, this may allow access to local files readable by the process or excessive memory use from large inline payloads. This issue has been fixed in version 2.74.1.

CVSS 8.1 · Alta · EPSS 0,4% · Corrección disponible

Publicación
Actualización

Pila tecnológica: python

Productos y versiones afectados

  • docling-core

    Versiones
    • >= 2.5.0, < 2.74.1: Afectada

    Sin corrección publicada

  • docling-core PyPI

    Versiones
    • 2.10.0
    • 2.11.0
    • 2.12.0
    • 2.12.1
    • 2.13.0
    • 2.13.1
    • 2.14.0
    • 2.15.0
    • 2.15.1
    • 2.16.0
    • 2.16.1
    • 2.17.0
    • 2.17.1
    • 2.17.2
    • 2.18.0
    • 2.18.1
    • 2.19.0
    • 2.19.1
    • 2.20.0
    • 2.21.0
    • 2.21.1
    • 2.21.2
    • 2.22.0
    • 2.23.0
    • 2.23.1
    • 2.23.2
    • 2.23.3
    • 2.24.0
    • 2.24.1
    • 2.25.0
    • 2.26.0
    • 2.26.1
    • 2.26.2
    • 2.26.3
    • 2.26.4
    • 2.27.0
    • 2.28.0
    • 2.28.1
    • 2.29.0
    • 2.30.0
    • 2.30.1
    • 2.31.0
    • 2.31.1
    • 2.31.2
    • 2.32.0
    • 2.33.0
    • 2.33.1
    • 2.34.0
    • 2.34.1
    • 2.34.2
    • 2.35.0
    • 2.36.0
    • 2.37.0
    • 2.38.0
    • 2.38.1
    • 2.38.2
    • 2.39.0
    • 2.40.0
    • 2.41.0
    • 2.42.0
    • 2.43.0
    • 2.43.1
    • 2.44.0
    • 2.44.1
    • 2.44.2
    • 2.45.0
    • 2.46.0
    • 2.47.0
    • 2.48.0
    • 2.48.1
    • 2.48.2
    • 2.48.3
    • 2.48.4
    • 2.49.0
    • 2.5.0
    • 2.5.1
    • 2.50.0
    • 2.50.1
    • 2.51.0
    • 2.51.1
    • 2.52.0
    • 2.53.0
    • 2.54.0
    • 2.54.1
    • 2.55.0
    • 2.56.0
    • 2.57.0
    • 2.58.0
    • 2.58.1
    • 2.59.0
    • 2.6.0
    • 2.6.1
    • 2.60.0
    • 2.60.1
    • 2.60.2
    • 2.61.0
    • 2.62.0
    • 2.63.0
    • 2.64.0
    • 2.65.0
    • 2.65.1
    • 2.65.2
    • 2.66.0
    • 2.67.0
    • 2.67.1
    • 2.68.0
    • 2.69.0
    • 2.7.0
    • 2.7.1
    • 2.70.0
    • 2.70.1
    • 2.70.2
    • 2.71.0
    • 2.72.0
    • 2.73.0
    • 2.74.0
    • 2.8.0
    • 2.9.0
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 2.5.0, < 2.74.1

    Actualiza a 2.74.1

Fuentes originales

Comprueba tu servidor →