CVE-2026-44512
CVE-2026-44512 · ONNX: Null Pointer Dereference in Upsample Version Converter Adapter (Zero Inputs)
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Open Neural Network Exchange (ONNX) is an open standard for machine learning interoperability. From 1.9.0 before 1.22.0, onnx.version_converter.convert_version() can dereference a null pointer in Upsample_6_7::adapt_upsample_6_7() in onnx/version_converter/adapters/upsample_6_7.h when processing an untrusted model with an Upsample node that has zero inputs, causing an unrecoverable denial of service. This issue is fixed in version 1.22.0.
CVSS 5.5 · Media · EPSS 0,2% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · python
Productos y versiones afectados
onnx
- Versiones
- >= 1.9.0, < 1.22.0: Afectada
Sin corrección publicada
onnx Debian:12
- Versiones
- 1.12.0-2
- 1.13.1-1
- 1.13.1-2
- 1.13.1-3
- 1.14.1-1
- 1.14.1-2
- 1.14.1-2.1
- 1.14.1-2.1~exp1
- 1.16.1-1
- 1.16.2-1
- 1.17.0-1
- 1.17.0-2
- 1.17.0-3
- 1.19.1-1~exp1
- 1.20.0-1
- 1.20.0-1~exp1
- 1.20.0-3
- 1.20.0-4
- 1.20.0-5
- 1.20.0-6
- 1.21.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
onnx Debian:13
- Versiones
- 1.17.0-3
- 1.19.1-1~exp1
- 1.20.0-1
- 1.20.0-1~exp1
- 1.20.0-3
- 1.20.0-4
- 1.20.0-5
- 1.20.0-6
- 1.21.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
onnx Debian:14
- Versiones
- 1.17.0-3
- 1.19.1-1~exp1
- 1.20.0-1
- 1.20.0-1~exp1
- 1.20.0-3
- 1.20.0-4
- 1.20.0-5
- 1.20.0-6
- 1.21.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
onnx PyPI
- Versiones
- 1.10.0
- 1.10.1
- 1.10.2
- 1.11.0
- 1.12.0
- 1.13.0
- 1.13.1
- 1.14.0
- 1.14.1
- 1.15.0
- 1.16.0
- 1.16.1
- 1.16.2
- 1.17.0
- 1.18.0
- 1.19.0
- 1.19.1
- 1.19.1rc1
- 1.20.0
- 1.20.0rc1
- 1.20.0rc2
- 1.20.1
- 1.20.1rc1
- 1.21.0
- 1.21.0rc1
- 1.21.0rc2
- 1.21.0rc3
- 1.21.0rc4
- 1.22.0rc1
- 1.22.0rc2
- 1.9.0
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 1.9.0, < 1.22.0
Actualiza a 1.22.0
onnx Ubuntu:22.04:LTS
- Versiones
- 1.7.0+dfsg-3build1
- 1.7.0+dfsg-3build2
- 1.7.0+dfsg-3ubuntu1
- 1.7.0+dfsg-3ubuntu2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
onnx Ubuntu:Pro:24.04:LTS
- Versiones
- 1.13.1-3
- 1.13.1-3build1
- 1.14.1-2
- 1.14.1-2.1
- 1.14.1-2.1build1
- 1.14.1-2.1build2
- 1.14.1-2.1ubuntu0.1~esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
onnx Ubuntu:25.10
- Versiones
- 1.17.0-3build1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
onnx Ubuntu:26.10
- Versiones
- 1.20.0-1
- 1.20.0-6
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
onnx Ubuntu:26.04:LTS
- Versiones
- 1.17.0-3build1
- 1.20.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada