p PatchFirst

CVE-2026-44581

CVE-2026-44581 · Next.js: Cross-site scripting in App Router applications using CSP nonces

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Next.js is a React framework for building full-stack web applications. From 13.4.0 to before 15.5.16 and 16.2.5, App Router applications that rely on CSP nonces can be vulnerable to stored cross-site scripting when deployed behind shared caches. In affected versions, malformed nonce values derived from request headers could be reflected into rendered HTML in an unsafe way, allowing an attacker to poison cached responses and cause script execution for later visitors. This vulnerability is fixed in 15.5.16 and 16.2.5.

CVSS 4.7 · Media · EPSS 0,2% · Corrección disponible

Publicación
Actualización

Pila tecnológica: node

Productos y versiones afectados

  • next.js

    Versiones
    • >= 13.4.0, < 15.5.16: Afectada
    • >= 16.0.0, < 16.2.5: Afectada

    Sin corrección publicada

  • next npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 13.4.0, < 15.5.16

    Actualiza a 15.5.16

  • next npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 16.0.0, < 16.2.5

    Actualiza a 16.2.5

Fuentes originales

Comprueba tu servidor →