p PatchFirst

CVE-2026-44583

CVE-2026-44583 · Paymenter: Blind Unauthenticated SSRF on the Paypal gateway module

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Paymenter is a free and open-source webshop solution for management of hosting services. In versions prior to 1.5.0, the PayPal webhook endpoint /extensions/paypal/webhook processes the PAYPAL-CERT-URL HTTP header without validation, allowing attackers to control server-side HTTP request destinations. This value is passed directly into a server-side HTTP request via file_get_contents, allowing attackers to control the destination of the request. No allowlist, validation, or signature verification is applied to the header before usage. As a result, the application can be coerced into performing HTTP requests to attacker-controlled or internal network destinations. This vulnerability allows remote unauthenticated attackers to induce server-side HTTP GET requests to arbitrary external or internal endpoints. Depending on network configuration, this may lead to: blind SSRF to external attacker-controlled systems, and potential access to internal network services No direct response data is returned to the attacker (blind SSRF), but the issue may still enable sensitive network probing or data exfiltration via side channels. This issue has been fixed in version 1.5.0.

CVSS 5.3 · Media · EPSS 0,4% · Corrección disponible

Publicación
Actualización

Pila tecnológica: php

Productos y versiones afectados

  • paymenter

    Versiones
    • < 1.5.0: Afectada

    Sin corrección publicada

  • paymenter/paymenter Packagist

    Versiones
    • 0.1
    • 0.1.1
    • 0.1.2
    • 0.1.3
    • 0.2
    • 0.2.1
    • v0.3
    • v0.4
    • v0.4.1
    • v0.5
    • v0.5.1
    • v0.5.2
    • v0.5.3
    • v0.6
    • v0.7
    • v0.7.1
    • v0.8
    • v0.8.1
    • v0.8.2
    • v0.9
    • v0.9.1
    • v0.9.2
    • v0.9.3
    • v0.9.4
    • v0.9.5
    • v1.0.0
    • v1.0.1
    • v1.0.2
    • v1.0.3
    • v1.0.4
    • v1.1.0
    • v1.1.1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.5.0

    Actualiza a 1.5.0

Fuentes originales

Comprueba tu servidor →