CVE-2026-45799
CVE-2026-45799 · Wire: skipGroup() missing negative-length check allows 10-byte payload to crash any Wire-decoding service
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Wire provides gRPC and protocol buffers for Android, Kotlin, Swift, and Java. Prior to 6.3.0 and 7.0.0-alpha03, ByteArrayProtoReader32.skipGroup() and ProtoReader.skipGroup() in wire-runtime do not validate that a LENGTH_DELIMITED field length is non-negative before skip(), allowing a crafted protobuf varint encoding -128 as a signed Int to make skip(-128) move the internal position negative and make the next readByte() throw ArrayIndexOutOfBoundsException instead of the documented IOException or ProtocolException, which can crash services using ProtoAdapter.decode(byte[]) on untrusted payloads. This issue is fixed in versions 6.3.0 and 7.0.0-alpha03.
CVSS 7.5 · Alta · EPSS 0,7%
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
wire
- Versiones
- < 6.3.0: Afectada
- >= 7.0.0-alpha01, < 7.0.0-alpha03: Afectada
Sin corrección publicada
grpc Ubuntu:16.04:LTS
- Versiones
- 0.10.2-1
- 0.11.1-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
grpc Ubuntu:18.04:LTS
- Versiones
- 1.3.2-1
- 1.3.2-1ubuntu1
- 1.3.2-1.1~build1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
grpc Ubuntu:20.04:LTS
- Versiones
- 1.16.1-1
- 1.16.1-1ubuntu1
- 1.16.1-1ubuntu3
- 1.16.1-1ubuntu4
- 1.16.1-1ubuntu5
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
grpc Ubuntu:22.04:LTS
- Versiones
- 1.30.2-3
- 1.30.2-3build1
- 1.30.2-3build3
- 1.30.2-3build5
- 1.30.2-3build6
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
grpc Ubuntu:24.04:LTS
- Versiones
- 1.51.1-3build3
- 1.51.1-3build4
- 1.51.1-4
- 1.51.1-4build1
- 1.51.1-4build2
- 1.51.1-4.1build3
- 1.51.1-4.1build4
- 1.51.1-4.1build5
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
grpc Ubuntu:26.10
- Versiones
- 1.51.1-8ubuntu1
- 1.51.1-9
- 1.51.1-9ubuntu3
- 1.51.1-10ubuntu1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
grpc Ubuntu:26.04:LTS
- Versiones
- 1.51.1-6build1
- 1.51.1-7
- 1.51.1-7ubuntu2
- 1.51.1-7ubuntu3
- 1.51.1-8ubuntu1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/square/wire/security/advisories/GHSA-7xpr-hc2w-34m9
- https://github.com/square/wire/pull/3595
- https://github.com/square/wire/pull/3597
- https://github.com/square/wire/commit/47d5b0dba53935d5332cd41a80a353b3fc90e7b0
- https://github.com/square/wire/commit/e4e56fab38a547d9625f05c97f1d8f0bcc3a5773
- https://github.com/square/wire/releases/tag/6.3.0
- https://github.com/square/wire/releases/tag/7.0.0-alpha03
- https://nvd.nist.gov/vuln/detail/CVE-2026-45799