p PatchFirst

CVE-2026-45804

CVE-2026-45804 · Diffusers: TOCTOU Trust Remote Code Bypass

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Diffusers is the a library for pretrained diffusion models. Prior to 0.38.0, Diffusers' DiffusionPipeline.from_pretrained flow can bypass the trust_remote_code guard because download() validates model_index.json and custom pipeline code before later loading from a cached folder that can change, allowing a Hub repository with custom .py pipeline code to execute through the custom pipeline flow without passing custom_pipeline or trust_remote_code=True. This issue is fixed in version 0.38.0.

CVSS 7.5 · Alta · EPSS 0,4% · Corrección disponible

Publicación
Actualización

Pila tecnológica: python

Productos y versiones afectados

  • diffusers

    Versiones
    • < 0.38.0: Afectada

    Sin corrección publicada

  • diffusers PyPI

    Versiones
    • 0.0.1
    • 0.0.2
    • 0.0.3
    • 0.0.4
    • 0.1.0
    • 0.1.1
    • 0.1.2
    • 0.1.3
    • 0.10.0
    • 0.10.1
    • 0.10.2
    • 0.11.0
    • 0.11.1
    • 0.12.0
    • 0.12.1
    • 0.13.0
    • 0.13.1
    • 0.14.0
    • 0.15.0
    • 0.15.1
    • 0.16.0
    • 0.16.1
    • 0.17.0
    • 0.17.1
    • 0.18.0
    • 0.18.1
    • 0.18.2
    • 0.19.0
    • 0.19.1
    • 0.19.2
    • 0.19.3
    • 0.2.0
    • 0.2.1
    • 0.2.2
    • 0.2.3
    • 0.2.4
    • 0.20.0
    • 0.20.1
    • 0.20.2
    • 0.21.0
    • 0.21.1
    • 0.21.2
    • 0.21.3
    • 0.21.4
    • 0.22.0
    • 0.22.1
    • 0.22.2
    • 0.22.3
    • 0.23.0
    • 0.23.1
    • 0.24.0
    • 0.25.0
    • 0.25.1
    • 0.26.0
    • 0.26.1
    • 0.26.2
    • 0.26.3
    • 0.27.0
    • 0.27.1
    • 0.27.2
    • 0.28.0
    • 0.28.1
    • 0.28.2
    • 0.29.0
    • 0.29.1
    • 0.29.2
    • 0.3.0
    • 0.30.0
    • 0.30.1
    • 0.30.2
    • 0.30.3
    • 0.31.0
    • 0.32.0
    • 0.32.1
    • 0.32.2
    • 0.33.0
    • 0.33.1
    • 0.34.0
    • 0.35.0
    • 0.35.1
    • 0.35.2
    • 0.36.0
    • 0.37.0
    • 0.37.1
    • 0.4.0
    • 0.4.1
    • 0.4.2
    • 0.5.0
    • 0.5.1
    • 0.6.0
    • 0.7.0
    • 0.7.1
    • 0.7.2
    • 0.8.0
    • 0.8.1
    • 0.9.0
    Intervalos de versiones afectados
    • ECOSYSTEM: < 0.38.0

    Actualiza a 0.38.0

Fuentes originales

Comprueba tu servidor →