CVE-2026-46417
CVE-2026-46417 · Angular: SSRF via Hostname Hijacking in @angular/platform-server
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 22.0.0-next.12, 21.2.13, 20.3.21, and 19.2.22, a Server-Side Request Forgery (SSRF) vulnerability exists in @angular/platform-server. The issue stems from how the server-side rendering (SSR) engine processes the request URL provided to the rendering entry points. When an absolute-form URL (e.g., http://evil.com) is passed to the rendering engine, the internal ServerPlatformLocation can be manipulated into adopting the attacker-controlled domain as the "current" hostname. Consequently, any relative HttpClient requests or PlatformLocation.hostname references are redirected to the attacker controlled server, potentially exposing internal APIs or metadata services. This vulnerability is fixed in 22.0.0-next.12, 21.2.13, 20.3.21, and 19.2.22.
CVSS 8.8 · Alta · EPSS 0,4% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · node
Productos y versiones afectados
angular
- Versiones
- >= 22.0.0-next.0, < 22.0.0-next.12: Afectada
- >= 21.0.0-next.0, < 21.2.13: Afectada
- >= 20.0.0-next.0, < 20.3.21: Afectada
- >= 19.0.0-next.0, < 19.2.22: Afectada
- <= 18.2.14: Afectada
Sin corrección publicada
angular.js Debian:12
- Versiones
- 1.8.3-1
- 1.8.3-1+deb12u1
- 1.8.3-1+deb12u1~deb11u1
- 1.8.3-2
- 1.8.3-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
angular.js Debian:13
- Versiones
- 1.8.3-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
@angular/platform-server npm
- Intervalos de versiones afectados
- SEMVER: ≥ 22.0.0-next.0, < 22.0.0-next.12
Actualiza a 22.0.0-next.12
@angular/platform-server npm
- Intervalos de versiones afectados
- SEMVER: ≥ 21.0.0-next.0, < 21.2.13
Actualiza a 21.2.13
@angular/platform-server npm
- Intervalos de versiones afectados
- SEMVER: ≥ 20.0.0-next.0, < 20.3.21
Actualiza a 20.3.21
@angular/platform-server npm
- Intervalos de versiones afectados
- SEMVER: ≥ 19.0.0-next.0, < 19.2.22
Actualiza a 19.2.22
@angular/platform-server npm
- Intervalos de versiones afectados
- SEMVER: ≤ 18.2.14
Sin corrección publicada
angular.js Ubuntu:Pro:16.04:LTS
- Versiones
- 1.2.28-1ubuntu2
- 1.2.28-1ubuntu2+esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
angular.js Ubuntu:Pro:18.04:LTS
- Versiones
- 1.5.10-1
- 1.5.10-1ubuntu0.1~esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
angular.js Ubuntu:Pro:20.04:LTS
- Versiones
- 1.5.10-1
- 1.7.9-1
- 1.7.9-1ubuntu0.1~esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
angular.js Ubuntu:22.04:LTS
- Versiones
- 1.8.2-2
- 1.8.2-2ubuntu0.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
angular.js Ubuntu:24.04:LTS
- Versiones
- 1.8.3-1
- 1.8.3-1ubuntu0.24.04.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
angular.js Ubuntu:25.10
- Versiones
- 1.8.3-1
- 1.8.3-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
angular.js Ubuntu:26.10
- Versiones
- 1.8.3-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
angular.js Ubuntu:26.04:LTS
- Versiones
- 1.8.3-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/angular/angular/security/advisories/GHSA-rfh7-fxqc-q52v
- https://github.com/angular/angular/pull/68570
- https://access.redhat.com/security/cve/CVE-2026-46417
- https://bugzilla.redhat.com/show_bug.cgi?id=2491444
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-46417.json
- https://nvd.nist.gov/vuln/detail/CVE-2026-46417