p PatchFirst

CVE-2026-48207

CVE-2026-48207 · Apache Fory: PyFory ReduceSerializer Incomplete Policy Enforcement

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Deserialization of untrusted data in Apache Fory PyFory. PyFory's ReduceSerializer could bypass documented DeserializationPolicy validation hooks during reduce-state restoration and global-name resolution. An application is vulnerable if it deserializes attacker-controlled data using PyFory Python-native mode with strict mode disabled and relies on DeserializationPolicy to restrict unsafe classes, functions, or module attributes. This issue affects Apache Fory: from before 1.0.0. Mitigation: Users of Apache Fory are recommended to upgrade to version 1.0.0 or later, which enforces DeserializationPolicy validation for the affected ReduceSerializer paths and thus fixes this issue.

CVSS 9.8 · Crítica · EPSS 0,6% · Corrección disponible

Publicación
Actualización

Pila tecnológica: python

Productos y versiones afectados

  • apache fory

    Versiones
    • ≥ 0.13.0, < 1.0.0: Afectada (semver)

    Actualiza a 1.0.0

  • pyfory PyPI

    Versiones
    • 0.13.0
    • 0.13.1
    • 0.13.2
    • 0.14.0
    • 0.14.1
    • 0.15.0
    • 0.16.0
    • 0.17.0
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 0.13.0, < 1.0.0

    Actualiza a 1.0.0

Fuentes originales

Comprueba tu servidor →