CVE-2026-48525
CVE-2026-48525 · PyJWT: Unauthenticated DoS via unbounded Base64URL decoding of unused payload segment in b64=false detached JWS
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
PyJWT is a JSON Web Token implementation in Python. From 2.8.0 to 2.12.1, when verifying detached JWS tokens using the unencoded-payload option ("b64": false, RFC 7797), PyJWT performs Base64URL decoding of the compact-serialization payload segment before enforcing the detached-payload rules. For b64=false, PyJWT later discards that decoded payload and replaces it with the caller-provided detached_payload. In practice, this turns the middle segment into an attacker-controlled “work amplifier”: a remote client can supply an arbitrarily large Base64URL payload segment that forces CPU work + memory allocations even if the signature is invalid. This creates an unauthenticated DoS vector against any endpoint that verifies detached JWS using PyJWT. This vulnerability is fixed in 2.13.0.
CVSS 5.3 · Media · EPSS 0,4% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · python
Productos y versiones afectados
pyjwt
- Versiones
- >= 2.8.0, < 2.13.0: Afectada
Sin corrección publicada
pyjwt Debian:12
- Versiones
- 2.10.1-1
- 2.10.1-2
- 2.10.1-3
- 2.10.1-4
- 2.11.0-2
- 2.12.1-1
- 2.13.0-1
- 2.14.0-1
- 2.15.0-1
- 2.15.1-1
- 2.6.0-1
- 2.6.0-1+deb12u1
- 2.7.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
pyjwt Debian:13
- Versiones
- 2.10.1-2
- 2.10.1-2+deb13u1
- 2.10.1-3
- 2.10.1-4
- 2.11.0-2
- 2.12.1-1
- 2.13.0-1
- 2.14.0-1
- 2.15.0-1
- 2.15.1-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
pyjwt Debian:14
- Versiones
- 2.10.1-2
- 2.10.1-3
- 2.10.1-4
- 2.11.0-2
- 2.12.1-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.13.0-1
Actualiza a 2.13.0-1
pyjwt PyPI
- Versiones
- 2.10.0
- 2.10.1
- 2.11.0
- 2.12.0
- 2.12.1
- 2.8.0
- 2.9.0
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 2.8.0, < 2.13.0
Actualiza a 2.13.0
pyjwt Ubuntu:24.04:LTS
- Versiones
- 2.7.0-1
- 2.7.0-1ubuntu0.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.7.0-1ubuntu0.2
Actualiza a 2.7.0-1ubuntu0.2
pyjwt Ubuntu:25.10
- Versiones
- 2.10.1-2
- 2.10.1-2ubuntu0.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
pyjwt Ubuntu:26.04:LTS
- Versiones
- 2.10.1-2
- 2.10.1-3
- 2.10.1-3build1
- 2.10.1-4
- 2.10.1-4ubuntu1
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.10.1-4ubuntu1.1
Actualiza a 2.10.1-4ubuntu1.1