CVE-2026-48979
CVE-2026-48979 · PHP Standard Library: HTTP/2 server-side missing content-length validation enables request smuggling
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
PHP Standard Library (PSL) is set of APIs covering async, collections, networking, I/O, cryptography, terminal UI, etc. In versions 6.1.0, 6.1.1 and 6.2.0, the Psl\H2\ServerConnection does not validate that the total bytes received in DATA frames match the content-length header declared in the HEADERS frame, allowing request smuggling. This is in violation of RFC 9113 §8.1.1. A malicious client is able to send more DATA bytes than declared, smuggling additional content past application-level size limits and send fewer DATA bytes than declared and close the stream early, causing applications that trust the declared length to behave incorrectly. The vulnerability is only reachable for consumers using Psl\H2\ServerConnection directly to accept untrusted client traffic. Consumers of documented high-level PSL APIs are not affected. This issue has been fixed in versions 6.1.2 and 6.2.1.
CVSS 7.5 · Alta · EPSS 0,3% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: php
Productos y versiones afectados
php-standard-library
- Versiones
- >= 6.1.0, < 6.1.2: Afectada
- >= 6.2.0, < 6.2.1: Afectada
Sin corrección publicada
php-standard-library/h2
- Versiones
- >= 6.1.0, < 6.1.2: Afectada
- >= 6.2.0, < 6.2.1: Afectada
Sin corrección publicada
php-standard-library/h2 Packagist
- Versiones
- 6.1.0
- 6.1.1
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 6.1.0, < 6.1.2
Actualiza a 6.1.2
php-standard-library/h2 Packagist
- Versiones
- 6.2.0
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 6.2.0, < 6.2.1
Actualiza a 6.2.1
php-standard-library/php-standard-library Packagist
- Versiones
- 6.1.0
- 6.1.1
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 6.1.0, < 6.1.2
Actualiza a 6.1.2
php-standard-library/php-standard-library Packagist
- Versiones
- 6.2.0
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 6.2.0, < 6.2.1
Actualiza a 6.2.1
Fuentes originales
- https://github.com/php-standard-library/php-standard-library/security/advisories/GHSA-pw9p-jvrm-f7rm
- https://github.com/php-standard-library/php-standard-library/releases/tag/6.1.2
- https://github.com/php-standard-library/php-standard-library/releases/tag/6.2.1
- https://nvd.nist.gov/vuln/detail/CVE-2026-48979