CVE-2026-48990
CVE-2026-48990 · joserfc: b64=false RFC7797 JWS payloads bypass JWSRegistry payload-size limits during deserialization
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
joserfc is a Python library that provides an implementation of several JSON Object Signing and Encryption (JOSE) standards. In versions 1.3.4 through 1.6.5, joserfc accepts oversized RFC7797 b64=false JWS payloads without applying JWSRegistry.max_payload_length, which can lead to resource exhaustion. The normal JWS compact and flattened JSON paths reject payloads above the configured payload-size limit with ExceededSizeError. The RFC7797 unencoded payload paths do not make the same check. A valid b64=false compact or flattened JSON JWS can therefore deserialize successfully with a payload larger than JWSRegistry.max_payload_length. Applications that accept lower-trust JWS values and rely on joserfc to reject oversized token content during verification have a moderate availability risk. This issue has been fixed in version 1.6.7.
CVSS 5.3 · Media · EPSS 0,2% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · python
Productos y versiones afectados
joserfc
- Versiones
- < 1.6.7: Afectada
Sin corrección publicada
joserfc Debian:13
- Versiones
- 1.1.0-1
- 1.2.0-1
- 1.2.2-1
- 1.3.1-1
- 1.3.2-1
- 1.3.4-1
- 1.4.0-1
- 1.4.1-1
- 1.4.3-1
- 1.5.0-1
- 1.6.0-1
- 1.6.1-1
- 1.6.2-1
- 1.6.3-1
- 1.6.4-1
- 1.6.5-1
- 1.6.8-1
- 1.7.0-1
- 1.7.1-1
- 1.7.2-1
- 1.7.3-1
- 1.7.4-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
joserfc Debian:14
- Versiones
- 1.1.0-1
- 1.2.0-1
- 1.2.2-1
- 1.3.1-1
- 1.3.2-1
- 1.3.4-1
- 1.4.0-1
- 1.4.1-1
- 1.4.3-1
- 1.5.0-1
- 1.6.0-1
- 1.6.1-1
- 1.6.2-1
- 1.6.3-1
- 1.6.4-1
- 1.6.5-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.6.8-1
Actualiza a 1.6.8-1
joserfc PyPI
- Versiones
- 1.3.4
- 1.3.5
- 1.4.0
- 1.4.1
- 1.4.2
- 1.4.3
- 1.5.0
- 1.6.0
- 1.6.1
- 1.6.2
- 1.6.3
- 1.6.4
- 1.6.5
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 1.3.4, < 1.6.7
Actualiza a 1.6.7
joserfc Ubuntu:25.10
- Versiones
- 1.0.4-1
- 1.1.0-1
- 1.2.0-1
- 1.2.2-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
joserfc Ubuntu:26.04:LTS
- Versiones
- 1.2.2-1
- 1.4.0-1
- 1.4.1-1
- 1.4.3-1
- 1.5.0-1
- 1.6.2-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada