p PatchFirst

CVE-2026-49284

CVE-2026-49284 · SimpleSAMLphp SP accepts a response from an unexpected IdP when unsigned `Response/InResponseTo` is combined with a signed assertion lacking `SubjectConfirmationData/InResponseTo`

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

SimpleSAMLphp versions before 1.18.6 contain an information disclosure vulnerability. Prior to 2.4.7 and 2.5.2, SimpleSAMLphp's SAML SP ACS path does not enforce the IdP selected for an SP-initiated login when unsigned Response/InResponseTo is combined with a signed assertion lacking SubjectConfirmationData/InResponseTo, allowing a response issued by one trusted IdP to be bound to SP state created for another IdP and bypass flows that route users to a specific IdP, including deployments that set enable_unsolicited to false. This issue is fixed in versions 2.4.7 and 2.5.2.

CVSS 7.1 · Alta · EPSS 0,2% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · php

Productos y versiones afectados

  • simplesamlphp

    Versiones
    • < 2.4.7: Afectada
    • >= 2.5.0-rc1, < 2.5.2: Afectada

    Sin corrección publicada

  • simplesamlphp Debian:12

    Versiones
    • 1.19.7-1
    • 1.19.7-1+deb12u1
    • 1.19.7-1+deb12u2
    • 1.19.7-2
    • 2.1.8-0.1
    • 2.2.6-1
    • 2.3.11-1
    • 2.3.11-2
    • 2.4.8-1
    • 2.5.3.1-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • simplesamlphp Debian:14

    Versiones
    • 1.10.0-1
    • 1.11.0-1
    • 1.12.0-1
    • 1.12.0~rc1-1
    • 1.12.0~rc2-1
    • 1.13.0-1
    • 1.13.1-1
    • 1.13.1-2
    • 1.13.2-1
    • 1.14.0-1
    • 1.14.1-1
    • 1.14.10-1
    • 1.14.11-1
    • 1.14.15-1
    • 1.14.2-1
    • 1.14.2-2
    • 1.14.3-1
    • 1.14.4-1
    • 1.14.5-1
    • 1.14.6-1
    • 1.14.7-1
    • 1.14.8-1
    • 1.14.9-1
    • 1.15.0-1
    • 1.15.1-1
    • 1.15.2-1
    • 1.15.3-1
    • 1.15.4-1
    • 1.16.0-1
    • 1.16.1-1
    • 1.16.2-1
    • 1.16.3-1
    • 1.17.0-1
    • 1.17.1-1
    • 1.17.2-1
    • 1.17.2-2
    • 1.17.3-1
    • 1.17.4-1
    • 1.17.5-1
    • 1.17.6-1
    • 1.17.6-2
    • 1.18.1-1
    • 1.18.4-1
    • 1.18.5-1
    • 1.18.6-1
    • 1.18.7-1
    • 1.18.8-1
    • 1.19.0-1
    • 1.19.1-1
    • 1.19.1-1.1
    • 1.19.6-1
    • 1.19.7-1
    • 1.19.7-2
    • 1.6.0-1
    • 1.6.1-1
    • 1.6.2-1
    • 1.6.3-1
    • 1.6.3-2
    • 1.6.3-3
    • 1.7.0-1
    • 1.7.0-2
    • 1.8.0-1
    • 1.8.1-1
    • 1.8.2-1
    • 1.9.0-1
    • 1.9.0~rc1-1
    • 1.9.0~rc2-1
    • 1.9.1-1
    • 1.9.2-1
    • 2.1.8-0.1
    • 2.2.6-1
    • 2.3.11-1
    • 2.3.11-2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.4.8-1

    Actualiza a 2.4.8-1

  • simplesamlphp/simplesamlphp Packagist

    Versiones
    • v2.5.0
    • v2.5.1
    Intervalos de versiones afectados
    • ECOSYSTEM: ≥ 2.5.0, < 2.5.2

    Actualiza a 2.5.2

  • simplesamlphp/simplesamlphp Packagist

    Versiones
    • 1.16.0
    • 1.16.0-rc1
    • 1.16.1
    • 1.16.2
    • 1.16.3
    • 1.19.8
    • 1.19.9
    • 2.0.2
    • 2.0.3
    • 2.0.4
    • 2.0.4-alpha.1
    • 2.0.5
    • 2.1.0
    • 2.1.0-rc1
    • v1.12.0
    • v1.13.0
    • v1.13.0-rc1
    • v1.13.0-rc2
    • v1.13.1
    • v1.13.2
    • v1.14.0
    • v1.14.0-rc1
    • v1.14.1
    • v1.14.10
    • v1.14.11
    • v1.14.12
    • v1.14.13
    • v1.14.14
    • v1.14.15
    • v1.14.16
    • v1.14.17
    • v1.14.2
    • v1.14.3
    • v1.14.4
    • v1.14.5
    • v1.14.6
    • v1.14.7
    • v1.14.8
    • v1.14.9
    • v1.15.0
    • v1.15.0-rc1
    • v1.15.0-rc2
    • v1.15.0-rc3
    • v1.15.1
    • v1.15.2
    • v1.15.3
    • v1.15.4
    • v1.17.0
    • v1.17.0-rc1
    • v1.17.0-rc2
    • v1.17.0-rc3
    • v1.17.1
    • v1.17.2
    • v1.17.3
    • v1.17.4
    • v1.17.5
    • v1.17.6
    • v1.17.7
    • v1.17.8
    • v1.18.0
    • v1.18.0-rc1
    • v1.18.0-rc2
    • v1.18.1
    • v1.18.2
    • v1.18.3
    • v1.18.4
    • v1.18.5
    • v1.18.6
    • v1.18.7
    • v1.18.8
    • v1.19.0
    • v1.19.0-rc1
    • v1.19.1
    • v1.19.2
    • v1.19.3
    • v1.19.4
    • v1.19.5
    • v1.19.6
    • v1.19.7
    • v2.0.0
    • v2.0.0-beta.1
    • v2.0.0-beta.11
    • v2.0.0-beta.2
    • v2.0.0-beta.3
    • v2.0.0-beta.4
    • v2.0.0-beta99
    • v2.0.0-rc1
    • v2.0.0-rc2
    • v2.0.0-rc3
    • v2.0.1
    • v2.0.10
    • v2.0.11
    • v2.0.12
    • v2.0.13
    • v2.0.14
    • v2.0.15
    • v2.0.6
    • v2.0.7
    • v2.0.8
    • v2.0.9
    • v2.1.1
    • v2.1.2
    • v2.1.3
    • v2.1.4
    • v2.1.5
    • v2.1.6
    • v2.1.7
    • v2.1.8
    • v2.2.0
    • v2.2.1
    • v2.2.2
    • v2.2.3
    • v2.2.4
    • v2.2.5
    • v2.2.6
    • v2.3.0
    • v2.3.1
    • v2.3.10
    • v2.3.11
    • v2.3.2
    • v2.3.3
    • v2.3.4
    • v2.3.5
    • v2.3.6
    • v2.3.7
    • v2.3.8
    • v2.3.9
    • v2.4.0
    • v2.4.1
    • v2.4.2
    • v2.4.3
    • v2.4.4
    • v2.4.5
    • v2.4.6
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.4.7

    Actualiza a 2.4.7

  • simplesamlphp Ubuntu:Pro:16.04:LTS

    Versiones
    • 1.13.2-1
    • 1.14.0-1
    • 1.14.0-1ubuntu2
    • 1.14.0-1ubuntu2+esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • simplesamlphp Ubuntu:Pro:18.04:LTS

    Versiones
    • 1.14.15-1
    • 1.15.0-1
    • 1.15.1-1
    • 1.15.2-1
    • 1.15.3-1
    • 1.15.3-1ubuntu0.1~esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • simplesamlphp Ubuntu:Pro:20.04:LTS

    Versiones
    • 1.17.5-1
    • 1.17.6-1
    • 1.17.6-2
    • 1.18.1-1
    • 1.18.4-1
    • 1.18.4-1ubuntu0.1~esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • simplesamlphp Ubuntu:Pro:22.04:LTS

    Versiones
    • 1.19.1-1
    • 1.19.1-1.1
    • 1.19.1-1.1ubuntu0.1~esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • simplesamlphp Ubuntu:24.04:LTS

    Versiones
    • 1.19.7-1
    • 1.19.7-1+deb12u1ubuntu0.1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • simplesamlphp Ubuntu:26.10

    Versiones
    • 1.19.7-2
    • 2.1.8-0.1
    • 2.2.6-1
    • 2.3.11-1
    • 2.3.11-2
    • 2.4.8-1
    • 2.5.3.1-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • simplesamlphp Ubuntu:26.04:LTS

    Versiones
    • 1.19.7-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →