CVE-2026-50178
CVE-2026-50178 · Angular: Remote Code Execution via JSDoc Hover Command Injection in VS Code Angular Language Service Extension
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
The Angular Language Service VS Code Extension provides a rich editing experience for Angular templates. the client-side Angular Language Service VS Code extension configures the tooltip Markdown renderer with the isTrusted: true option (located in client/src/client.ts). This setting instructs VS Code to trust all rendered content it receives, which enables active elements such as command: URIs. However, the background Angular Language Server process fails to escape or sanitize brackets, raw links, and control characters from JSDoc strings before forwarding the hover Markdown content (located in server/src/handlers/hover.ts and server/src/text_render.ts). An attacker can leverage this behavior by crafting a project TypeScript or JavaScript file (or a third-party npm package dependency) containing a malicious JSDoc tooltip with an embedded active command link. When a developer hovers over the target symbol to render the tooltip and clicks the malicious link, the IDE executes the command sequence directly on the developer's host machine. Prior to 21.2.4, This vulnerability is fixed in 21.2.4.
CVSS 8.7 · Alta · EPSS 0,5%
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
angular
- Versiones
- < 21.2.4: Afectada
Sin corrección publicada
angular.ng-template
- Versiones
- < 21.2.4: Afectada
Sin corrección publicada
angular.js Ubuntu:Pro:16.04:LTS
- Versiones
- 1.2.28-1ubuntu2
- 1.2.28-1ubuntu2+esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
angular.js Ubuntu:Pro:18.04:LTS
- Versiones
- 1.5.10-1
- 1.5.10-1ubuntu0.1~esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
angular.js Ubuntu:Pro:20.04:LTS
- Versiones
- 1.5.10-1
- 1.7.9-1
- 1.7.9-1ubuntu0.1~esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
angular.js Ubuntu:22.04:LTS
- Versiones
- 1.8.2-2
- 1.8.2-2ubuntu0.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
angular.js Ubuntu:24.04:LTS
- Versiones
- 1.8.3-1
- 1.8.3-1ubuntu0.24.04.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
angular.js Ubuntu:25.10
- Versiones
- 1.8.3-1
- 1.8.3-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
angular.js Ubuntu:26.10
- Versiones
- 1.8.3-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
angular.js Ubuntu:26.04:LTS
- Versiones
- 1.8.3-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada