p PatchFirst

CVE-2026-50195

CVE-2026-50195 · containerd: CRI checkpoint import allows local image tag poisoning

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

containerd is an open-source container runtime. Versions prior to 2.3.2, 2.2.5 and 2.1.9 contain a vulnerability in the CRI checkpoint import process where it fails to validate the image references specified within a checkpoint image's configuration. An attacker with permissions to create pods can use a crafted checkpoint image to force containerd to pull a malicious image and assign it an arbitrary local tag, thereby poisoning the node's local image cache. Subsequently, if other pods on the same node attempt to use the poisoned tag with an IfNotPresent (or Never) pull policy, they will unknowingly execute the attacker's malicious image instead of the legitimate one. This can lead to a compromise of the affected pods, allowing the attacker to execute arbitrary code under the victim pod's identity. This issue has been fixed in versions 2.3.2, 2.2.5 and 2.1.9.

CVSS 5.6 · Media · EPSS 0,3% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · containers

Productos y versiones afectados

  • containerd

    Versiones
    • >= 2.1.0, < 2.1.9: Afectada
    • >= 2.2.0, < 2.2.5: Afectada
    • >= 2.3.0, < 2.3.2: Afectada

    Sin corrección publicada

  • containerd Debian:14

    Versiones
    • 1.7.24~ds1-10
    • 1.7.24~ds1-6
    • 1.7.24~ds1-7
    • 1.7.24~ds1-8
    • 1.7.24~ds1-9
    • 2.1.4~ds2-2
    • 2.1.4~ds2-3
    • 2.1.4~ds2-4
    • 2.1.4~ds2-5
    • 2.1.4~ds2-6
    • 2.1.4~ds2-7
    • 2.1.4~ds2-8
    • 2.1.6+ds1-1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.1.9+ds1-1

    Actualiza a 2.1.9+ds1-1

  • containerd-app Ubuntu:22.04:LTS

    Versiones
    • 1.7.2-0ubuntu1~22.04.1
    • 1.7.12-0ubuntu2~22.04.1
    • 1.7.24-0ubuntu1~22.04.1
    • 1.7.24-0ubuntu1~22.04.2
    • 1.7.27-0ubuntu1~22.04.1
    • 1.7.28-0ubuntu1~22.04.1
    • 2.2.1-0ubuntu1~22.04.1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.2.1-0ubuntu1~22.04.2

    Actualiza a 2.2.1-0ubuntu1~22.04.2

  • containerd-app Ubuntu:24.04:LTS

    Versiones
    • 1.7.2-0ubuntu2
    • 1.7.12-0ubuntu1
    • 1.7.12-0ubuntu2
    • 1.7.12-0ubuntu3
    • 1.7.12-0ubuntu4
    • 1.7.12-0ubuntu4.1
    • 1.7.19-0ubuntu1~24.04.1
    • 1.7.19+really1.7.12-0ubuntu4.2
    • 1.7.24-0ubuntu1~24.04.1
    • 1.7.24-0ubuntu1~24.04.2
    • 1.7.27-0ubuntu1~24.04.1
    • 1.7.28-0ubuntu1~24.04.1
    • 1.7.28-0ubuntu1~24.04.2
    • 2.2.1-0ubuntu1~24.04.2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.2.1-0ubuntu1~24.04.3

    Actualiza a 2.2.1-0ubuntu1~24.04.3

  • containerd-app Ubuntu:25.10

    Versiones
    • 2.0.2-0ubuntu2
    • 2.0.5-0ubuntu1
    • 2.1.3-0ubuntu2
    • 2.1.3-0ubuntu3
    • 2.1.3-0ubuntu3.1
    • 2.2.1-0ubuntu1~25.10.1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.2.1-0ubuntu1~25.10.2

    Actualiza a 2.2.1-0ubuntu1~25.10.2

  • containerd-stable Ubuntu:25.10

    Versiones
    • 2.1.3-0ubuntu1
    • 2.1.6-0ubuntu1~25.10.1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.1.6-0ubuntu1~25.10.2

    Actualiza a 2.1.6-0ubuntu1~25.10.2

  • containerd-app Ubuntu:26.04:LTS

    Versiones
    • 2.1.3-0ubuntu3
    • 2.2.1-0ubuntu1
    • 2.2.2-0ubuntu1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.2.2-0ubuntu1.1

    Actualiza a 2.2.2-0ubuntu1.1

  • containerd-stable Ubuntu:26.04:LTS

    Versiones
    • 2.1.3-0ubuntu1
    • 2.1.5-0ubuntu1
    • 2.2.1-0ubuntu1
    • 2.2.2-0ubuntu1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.2.2-0ubuntu1.1

    Actualiza a 2.2.2-0ubuntu1.1

Fuentes originales

Comprueba tu servidor →