p PatchFirst

CVE-2026-50555

CVE-2026-50555 · Angular: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in @angular/platform-server

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 22.0.0-rc.2, 21.2.16, 20.3.24, and 19.2.25, a Cross-Site Scripting (XSS) vulnerability exists in @angular/platform-server's DOM emulation dependency (domino) when serializing the content of raw-text elements (such as <script>, <style>, and <iframe>). domino supports escaping raw-text elements during serialization to prevent closing-tag breakout. However, a Unicode index alignment bug existed in this escaping logic. In JavaScript, string lengths and character indices are calculated based on UTF-16 code units (where astral characters—such as emojis—occupy 2 code units / 4 bytes). If the bound dynamic text contained astral Unicode characters before the closing tag (e.g. </script>, </style>, or </iframe>), the index offset calculation in domino's replacement logic shifted. This misalignment caused domino to fail to replace or escape the closing tag, leaving it raw and unescaped in the output HTML. An attacker who controls the dynamic text can supply a payload containing both an astral Unicode character and a closing tag (e.g., 😀</iframe><script>alert(1)</script>). When serialized on the server during SSR, the browser parses the unescaped closing tag, exits the raw-text context early, and executes the subsequent <script> block, leading to same-origin Cross-Site Scripting (XSS). This vulnerability is fixed in 22.0.0-rc.2, 21.2.16, 20.3.24, and 19.2.25.

CVSS 8.6 · Alta · EPSS 0,3% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · node

Productos y versiones afectados

  • angular

    Versiones
    • >= 22.0.0-next.0, < 22.0.0-rc.2: Afectada
    • >= 21.0.0-next.0, < 21.2.16: Afectada
    • >= 20.0.0-next.0, < 20.3.24: Afectada
    • >= 19.0.0-next.0, < 19.2.25: Afectada
    • <= 18.2.14: Afectada

    Sin corrección publicada

  • angular.js Debian:12

    Versiones
    • 1.8.3-1
    • 1.8.3-1+deb12u1
    • 1.8.3-1+deb12u1~deb11u1
    • 1.8.3-2
    • 1.8.3-3
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • angular.js Debian:13

    Versiones
    • 1.8.3-3
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • @angular/platform-server npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 22.0.0-next.0, < 22.0.0-rc.2

    Actualiza a 22.0.0-rc.2

  • @angular/platform-server npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 21.0.0-next.0, < 21.2.16

    Actualiza a 21.2.16

  • @angular/platform-server npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 20.0.0-next.0, < 20.3.24

    Actualiza a 20.3.24

  • @angular/platform-server npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 19.0.0-next.0, < 19.2.25

    Actualiza a 19.2.25

  • @angular/platform-server npm

    Intervalos de versiones afectados
    • SEMVER: ≤ 18.2.14

    Sin corrección publicada

  • angular.js Ubuntu:Pro:16.04:LTS

    Versiones
    • 1.2.28-1ubuntu2
    • 1.2.28-1ubuntu2+esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • angular.js Ubuntu:Pro:18.04:LTS

    Versiones
    • 1.5.10-1
    • 1.5.10-1ubuntu0.1~esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • angular.js Ubuntu:Pro:20.04:LTS

    Versiones
    • 1.5.10-1
    • 1.7.9-1
    • 1.7.9-1ubuntu0.1~esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • angular.js Ubuntu:22.04:LTS

    Versiones
    • 1.8.2-2
    • 1.8.2-2ubuntu0.1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • angular.js Ubuntu:24.04:LTS

    Versiones
    • 1.8.3-1
    • 1.8.3-1ubuntu0.24.04.1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • angular.js Ubuntu:25.10

    Versiones
    • 1.8.3-1
    • 1.8.3-3
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • angular.js Ubuntu:26.10

    Versiones
    • 1.8.3-3
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • angular.js Ubuntu:26.04:LTS

    Versiones
    • 1.8.3-3
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →