p PatchFirst

CVE-2026-53956

CVE-2026-53956 · Rattler vulnerable to package cache path traversal via conda package build string

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Rattler is a library that provides common functionality used within the conda ecosystem. `rattler_cache` prior to version 0.9.0 and `py-rattler` prior to version 0.24.0 were vulnerable to package-cache path traversal when handling package metadata from conda channels. During cache materialization, the `ratter_cache` code used the package record `build` string as part of a cache key that was joined into a filesystem path. A malicious or untrusted channel could publish repodata with path separators or traversal components in that field, causing package contents to be written outside the configured package cache directory. The issue requires use of a malicious or otherwise untrusted conda channel. Curated channels that validate package metadata are not expected to allow malformed build strings of this form. Users should upgrade to `rattler_cache` version 0.9.0 or `py-rattler` version 0.24.0 and avoid untrusted conda channels.

CVSS 5.4 · Media · EPSS 0,3% · Corrección disponible

Publicación
Actualización

Pila tecnológica: python

Productos y versiones afectados

  • rattler_cache

    Versiones
    • < 0.9.0: Afectada

    Sin corrección publicada

  • py-rattler

    Versiones
    • < 0.24.0: Afectada

    Sin corrección publicada

  • rattler_cache crates.io

    Intervalos de versiones afectados
    • SEMVER: < 0.9.0

    Actualiza a 0.9.0

  • py-rattler PyPI

    Versiones
    • 0.1.0
    • 0.1.1
    • 0.1.2
    • 0.10.0
    • 0.11.0
    • 0.12.0
    • 0.13.0
    • 0.13.1
    • 0.14.0
    • 0.15.0
    • 0.16.0
    • 0.17.0
    • 0.18.0
    • 0.19.0
    • 0.2.0
    • 0.2.1
    • 0.20.0
    • 0.21.0
    • 0.22.0
    • 0.23.0
    • 0.23.1
    • 0.23.2
    • 0.3.0
    • 0.4.0
    • 0.5.0
    • 0.6.0
    • 0.6.1
    • 0.6.2
    • 0.6.3
    • 0.7.0
    • 0.7.1
    • 0.7.2
    • 0.8.0
    • 0.8.2
    • 0.9.0
    • 0.9.1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 0.24.0

    Actualiza a 0.24.0

Fuentes originales

Comprueba tu servidor →