CVE-2026-54180
CVE-2026-54180 · backpack/crud: CRUD panel query scopes are not enforced on Update, Delete, and Reorder (cross-tenant IDOR)
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
backpack/crud provides Create, Read, Update & Delete (CRUD) functions for Backpack, a collection of Laravel packages that help users build custom administration panels. From 6.0.0 until 6.8.14 and 7.0.38, the Update, Delete, and Reorder operations resolve records from the unscoped model query instead of the query configured through addClause() or addBaseClause(). An authenticated user who knows or guesses an out-of-scope record primary key can therefore modify, delete, or reorder records hidden by tenant, ownership, or other row-level access-control scopes. Applications that do not rely on CRUD query clauses for authorization are not affected by this specific bypass. The fix routes all three write operations through getModelWithCrudPanelQuery(), matching the scoped list and read behavior. This issue is fixed in versions 6.8.14 and 7.0.38.
CVSS 7.6 · Alta · EPSS 0,5% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: php
Productos y versiones afectados
crud
- Versiones
- >= 6.0.0, < 6.8.14: Afectada
- >= 7.0.0, < 7.0.38: Afectada
Sin corrección publicada
backpack/crud Packagist
- Versiones
- 6.0.0
- 6.0.1
- 6.0.2
- 6.0.3
- 6.0.4
- 6.0.5
- 6.0.6
- 6.0.7
- 6.1.0
- 6.1.1
- 6.1.10
- 6.1.11
- 6.1.12
- 6.1.13
- 6.1.14
- 6.1.15
- 6.1.16
- 6.1.2
- 6.1.3
- 6.1.4
- 6.1.5
- 6.1.6
- 6.1.7
- 6.1.8
- 6.1.9
- 6.2.0
- 6.2.1
- 6.2.2
- 6.2.3
- 6.2.4
- 6.3.0
- 6.3.1
- 6.3.2
- 6.4.0
- 6.4.1
- 6.4.2
- 6.5.0
- 6.5.1
- 6.5.2
- 6.5.3
- 6.5.4
- 6.5.5
- 6.6.0
- 6.6.1
- 6.6.2
- 6.6.3
- 6.6.4
- 6.6.5
- 6.6.6
- 6.7.0
- 6.7.1
- 6.7.10
- 6.7.11
- 6.7.12
- 6.7.13
- 6.7.14
- 6.7.15
- 6.7.16
- 6.7.17
- 6.7.18
- 6.7.19
- 6.7.2
- 6.7.20
- 6.7.21
- 6.7.22
- 6.7.23
- 6.7.24
- 6.7.25
- 6.7.26
- 6.7.27
- 6.7.28
- 6.7.29
- 6.7.3
- 6.7.30
- 6.7.31
- 6.7.32
- 6.7.33
- 6.7.34
- 6.7.35
- 6.7.36
- 6.7.37
- 6.7.38
- 6.7.39
- 6.7.4
- 6.7.40
- 6.7.41
- 6.7.42
- 6.7.43
- 6.7.44
- 6.7.45
- 6.7.46
- 6.7.47
- 6.7.48
- 6.7.49
- 6.7.5
- 6.7.50
- 6.7.51
- 6.7.52
- 6.7.53
- 6.7.54
- 6.7.55
- 6.7.56
- 6.7.6
- 6.7.7
- 6.7.8
- 6.7.9
- 6.8.0
- 6.8.1
- 6.8.10
- 6.8.11
- 6.8.12
- 6.8.13
- 6.8.2
- 6.8.3
- 6.8.4
- 6.8.5
- 6.8.6
- 6.8.7
- 6.8.8
- 6.8.9
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 6.0.0, < 6.8.14
Actualiza a 6.8.14
backpack/crud Packagist
- Versiones
- 7.0.0
- 7.0.1
- 7.0.10
- 7.0.11
- 7.0.12
- 7.0.13
- 7.0.14
- 7.0.15
- 7.0.16
- 7.0.17
- 7.0.18
- 7.0.19
- 7.0.2
- 7.0.20
- 7.0.21
- 7.0.22
- 7.0.23
- 7.0.24
- 7.0.25
- 7.0.26
- 7.0.27
- 7.0.28
- 7.0.29
- 7.0.3
- 7.0.30
- 7.0.31
- 7.0.32
- 7.0.33
- 7.0.34
- 7.0.35
- 7.0.36
- 7.0.37
- 7.0.4
- 7.0.5
- 7.0.6
- 7.0.7
- 7.0.8
- 7.0.9
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 7.0.0, < 7.0.38
Actualiza a 7.0.38
Fuentes originales
- https://github.com/Laravel-Backpack/CRUD/security/advisories/GHSA-vgmv-8xjc-6rch
- https://github.com/Laravel-Backpack/CRUD/pull/5991
- https://github.com/Laravel-Backpack/CRUD/pull/5994
- https://github.com/Laravel-Backpack/CRUD/commit/76c3a6e50e3fbd6d5f633208da5b04acb8322969
- https://github.com/Laravel-Backpack/CRUD/commit/dd25c2086b8ea2cb765993b65876c66ab824eef0
- https://github.com/Laravel-Backpack/CRUD/releases/tag/6.8.14
- https://github.com/Laravel-Backpack/CRUD/releases/tag/7.0.38
- https://nvd.nist.gov/vuln/detail/CVE-2026-54180