CVE-2026-54293
CVE-2026-54293 · NLTK: URL-Encoded Path Traversal in nltk.data.load() Allows Arbitrary Local File Read
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
NLTK (Natural Language Toolkit) is a suite of open source Python modules, data sets, and tutorials supporting research and development in Natural Language Processing. Prior to 3.10.0-rc1, nltk.data.load() in NLTK is vulnerable to path traversal via URL-encoded path separators and traversal segments when using the nltk: URL scheme. The unsafe-path regex check is performed before url2pathname() decodes the %xx sequences (a classic decode-after-check / TOCTOU-style flaw), allowing an attacker to bypass the protection documented in NLTK's SECURITY.md and read arbitrary files from the filesystem. While literal traversal strings such as ../../../etc/passwd are correctly blocked, encoded variants such as %2fetc%2fpasswd, %2e%2e%2f..., and ..%2f..%2f slip past the regex and are subsequently decoded into a real filesystem path. This vulnerability is fixed in 3.10.0-rc1.
CVSS 7.5 · Alta · EPSS 0,6% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · python
Productos y versiones afectados
nltk
- Versiones
- < 3.10.0-rc1: Afectada
Sin corrección publicada
nltk Debian:12
- Versiones
- 3.10.0-1
- 3.10.1-1
- 3.10.3-1
- 3.8-1
- 3.8.1-1
- 3.9.1-1
- 3.9.1-2
- 3.9.2-1
- 3.9.3-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
nltk Debian:13
- Versiones
- 3.10.0-1
- 3.10.1-1
- 3.10.3-1
- 3.9.1-2
- 3.9.2-1
- 3.9.3-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
nltk Debian:14
- Versiones
- 3.9.1-2
- 3.9.2-1
- 3.9.3-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.10.0-1
Actualiza a 3.10.0-1
nltk PyPI
- Versiones
- 0.8
- 0.9
- 0.9.3
- 0.9.4
- 0.9.5
- 0.9.6
- 0.9.7
- 0.9.8
- 0.9.9
- 2.0.1
- 2.0.1rc1
- 2.0.1rc2-git
- 2.0.1rc3
- 2.0.1rc4
- 2.0.2
- 2.0.3
- 2.0.4
- 2.0.5
- 2.0b4
- 2.0b5
- 2.0b6
- 2.0b7
- 2.0b8
- 2.0b9
- 3.0.0
- 3.0.0b1
- 3.0.0b2
- 3.0.1
- 3.0.2
- 3.0.3
- 3.0.4
- 3.0.5
- 3.1
- 3.2
- 3.2.1
- 3.2.2
- 3.2.3
- 3.2.4
- 3.2.5
- 3.3
- 3.4
- 3.4.1
- 3.4.2
- 3.4.3
- 3.4.4
- 3.4.5
- 3.5
- 3.5b1
- 3.6
- 3.6.1
- 3.6.2
- 3.6.3
- 3.6.4
- 3.6.5
- 3.6.6
- 3.6.7
- 3.7
- 3.8
- 3.8.1
- 3.9
- 3.9.1
- 3.9.2
- 3.9.3
- 3.9.4
- 3.9b1
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.10.0
Actualiza a 3.10.0
nltk Ubuntu:Pro:14.04:LTS
- Versiones
- 2.0~b9-0ubuntu4
- 2.0~b9-0ubuntu4.1~esm2
- 2.0~b9-0ubuntu4.1~esm4
- 2.0~b9-0ubuntu4.1~esm5
- 2.0~b9-0ubuntu4.1~esm6
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
nltk Ubuntu:Pro:16.04:LTS
- Versiones
- 3.0.4-1
- 3.0.5-1
- 3.1-1
- 3.1-1ubuntu0.1
- 3.1-1ubuntu0.1+esm1
- 3.1-1ubuntu0.1+esm2
- 3.1-1ubuntu0.1+esm3
- 3.1-1ubuntu0.1+esm4
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
nltk Ubuntu:Pro:18.04:LTS
- Versiones
- 3.2.4-1
- 3.2.5-1
- 3.2.5-1ubuntu0.1
- 3.2.5-1ubuntu0.1+esm1
- 3.2.5-1ubuntu0.1+esm2
- 3.2.5-1ubuntu0.1+esm3
- 3.2.5-1ubuntu0.1+esm4
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
nltk Ubuntu:Pro:20.04:LTS
- Versiones
- 3.4.5-1
- 3.4.5-2
- 3.4.5-2ubuntu0.1~esm1
- 3.4.5-2ubuntu0.1~esm2
- 3.4.5-2ubuntu0.1~esm3
- 3.4.5-2ubuntu0.1~esm4
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
nltk Ubuntu:Pro:22.04:LTS
- Versiones
- 3.5-1
- 3.6.5-1
- 3.6.7-1
- 3.7-1
- 3.7-1ubuntu0.1~esm1
- 3.7-1ubuntu0.1~esm2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
nltk Ubuntu:Pro:24.04:LTS
- Versiones
- 3.8.1-1
- 3.8.1-1ubuntu0.1~esm1
- 3.8.1-1ubuntu0.1~esm2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
nltk Ubuntu:25.10
- Versiones
- 3.9.1-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
nltk Ubuntu:26.10
- Versiones
- 3.9.2-1
- 3.9.3-1
- 3.10.0-1
- 3.10.1-1
- 3.10.3-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
nltk Ubuntu:Pro:26.04:LTS
- Versiones
- 3.9.1-2
- 3.9.1-2build1
- 3.9.2-1
- 3.9.2-1ubuntu0.1~esm1
- 3.9.2-1ubuntu0.1~esm2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/nltk/nltk/security/advisories/GHSA-p4gq-832x-fm9v
- https://github.com/nltk/nltk/pull/3575
- https://access.redhat.com/security/cve/CVE-2026-54293
- https://bugzilla.redhat.com/show_bug.cgi?id=2491486
- https://security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-54293.json
- https://access.redhat.com/errata/RHSA-2026:42644
- https://access.redhat.com/errata/RHSA-2026:65126
- https://access.redhat.com/errata/RHSA-2026:60520
- https://nvd.nist.gov/vuln/detail/CVE-2026-54293