CVE-2026-54490
CVE-2026-54490 · websocket-driver: Resource limit bypass via message compression
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
websocket-driver is a WebSocket protocol handler with pluggable I/O. Prior to 0.7.5, if this library is used with the permessage-deflate extension, a WebSocket server or client can be made to accept messages that are larger than the configured maximum message size because the limit is checked against the message frames' length headers, which give the size of the compressed data, not the size after decompression in lib/websocket/driver/hybi.js. This can lead to applications accepting larger messages than expected and exceeding their intended resource usage. This issue is fixed in version 0.7.5.
CVSS 6.3 · Media · EPSS 0,4% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · node
Productos y versiones afectados
websocket-driver-node
- Versiones
- < 0.7.5: Afectada
Sin corrección publicada
node-websocket-driver Debian:12
- Versiones
- 0.7.4+~cs0.6.14-1
- 0.7.4+~cs0.6.7-2
- 0.7.5+~cs0.6.14-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-websocket-driver Debian:13
- Versiones
- 0.7.4+~cs0.6.14-1
- 0.7.4+~cs0.6.7-2
- 0.7.5+~cs0.6.14-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-websocket-driver Debian:14
- Versiones
- 0.7.4+~cs0.6.14-1
- 0.7.4+~cs0.6.7-2
- Intervalos de versiones afectados
- ECOSYSTEM: < 0.7.5+~cs0.6.14-1
Actualiza a 0.7.5+~cs0.6.14-1
websocket-driver npm
- Intervalos de versiones afectados
- SEMVER: < 0.7.5
Actualiza a 0.7.5
node-websocket-driver Ubuntu:16.04:LTS
- Versiones
- 0.3.5-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-websocket-driver Ubuntu:18.04:LTS
- Versiones
- 0.3.5-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-websocket-driver Ubuntu:20.04:LTS
- Versiones
- 0.3.5-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-websocket-driver Ubuntu:22.04:LTS
- Versiones
- 0.7.4+~cs0.6.7-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-websocket-driver Ubuntu:24.04:LTS
- Versiones
- 0.7.4+~cs0.6.7-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-websocket-driver Ubuntu:26.10
- Versiones
- 0.7.4+~cs0.6.14-1
- 0.7.5+~cs0.6.14-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
node-websocket-driver Ubuntu:26.04:LTS
- Versiones
- 0.7.4+~cs0.6.7-2
- 0.7.4+~cs0.6.14-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada