p PatchFirst

CVE-2026-54559

CVE-2026-54559 · PocketSphinx: Buffer overflows in language and acoustic model loading code

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

PocketSphinx is a small speech recognizer. Prior to 5.1.1, the trie language-model loaders in src/lm/ngram_model_trie.c do not adequately validate boundary conditions in ARPA, DMP, and binary format headers, and the acoustic-model loaders in src/mdef.c and src/util/bio.c use sscanf with unbounded string fields. Loading an invalid, corrupted, or malicious language or acoustic model can therefore cause stack or heap buffer overflows and memory corruption. An attacker who can write to a directory selected by POCKETSPHINX_PATH can replace or add a model file that PocketSphinx later loads; users of PocketSphinx 5prealpha have no backported patch and must migrate to the fixed release. This issue is fixed in version 5.1.1.

CVSS 6.9 · Media · EPSS 0,5% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · python

Productos y versiones afectados

  • pocketsphinx

    Versiones
    • < 5.1.1: Afectada

    Sin corrección publicada

  • pocketsphinx PyPI

    Versiones
    • 0.0.1
    • 0.0.2
    • 0.0.3
    • 0.0.4
    • 0.0.5
    • 0.0.6
    • 0.0.7
    • 0.0.8
    • 0.0.9
    • 0.1.0
    • 0.1.10
    • 0.1.11
    • 0.1.12
    • 0.1.15
    • 0.1.3
    • 0.1.5
    • 0.1.7
    • 0.1.9
    • 5.0.0
    • 5.0.0rc3
    • 5.0.0rc4
    • 5.0.0rc5
    • 5.0.1
    • 5.0.2
    • 5.0.3
    • 5.0.4
    • 5.1.0
    • 5.1.0rc1
    • 5.1.0rc2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 5.1.1

    Actualiza a 5.1.1

  • pocketsphinx Ubuntu:16.04:LTS

    Versiones
    • 0.8.0+real-0ubuntu6
    • 0.8.0+real5prealpha-1ubuntu2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • pocketsphinx Ubuntu:18.04:LTS

    Versiones
    • 0.8.0+real5prealpha-1ubuntu2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • pocketsphinx Ubuntu:20.04:LTS

    Versiones
    • 0.8.0+real5prealpha+1-6ubuntu1
    • 0.8.0+real5prealpha+1-6ubuntu3
    • 0.8.0+real5prealpha+1-6ubuntu4
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • pocketsphinx Ubuntu:22.04:LTS

    Versiones
    • 0.8.0+real5prealpha+1-13ubuntu1
    • 0.8.0+real5prealpha+1-14ubuntu1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • pocketsphinx Ubuntu:24.04:LTS

    Versiones
    • 0.8.0+real5prealpha+1-15ubuntu1
    • 0.8.0+real5prealpha+1-15ubuntu4
    • 0.8.0+real5prealpha+1-15ubuntu5
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • pocketsphinx Ubuntu:26.10

    Versiones
    • 5.0.4-3ubuntu1
    • 5.0.4-4ubuntu1
    • 5.1.1-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • pocketsphinx Ubuntu:26.04:LTS

    Versiones
    • 0.8.0+real5prealpha+1-15ubuntu5
    • 0.8.0+real5prealpha+1-15ubuntu6
    • 5.0.4-3ubuntu1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →