CVE-2026-54604
CVE-2026-54604 · OpenSlide: openslide_read_region() returns uninitialized memory with libtiff 4.7.1
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
OpenSlide is a C library for reading whole slide image files. Prior to 4.0.1, a behavior change in libtiff 4.7.1 causes the indirect TIFF tile path in src/openslide-decode-tiff.c and _openslide_tiff_read_tile() to request a full-height destination for a partial bottom tile row, allowing uninitialized heap memory to enter pixel data returned by openslide_read_region(). A crafted but valid slide can trigger the issue in TIFF-based formats other than Hamamatsu NDPI when a network service renders attacker-provided slides. Successful extraction depends on pixel transparency handling and recompression, OpenSlide with libtiff 4.7.0 or earlier is not affected, and official binary builds 4.0.0.10 and 4.0.0.11 are affected. This issue is fixed in OpenSlide 4.0.1 and official binary build 4.0.0.12.
CVSS 5.3 · Media · EPSS 0,5% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
openslide
- Versiones
- < 4.0.1: Afectada
Sin corrección publicada
openslide Debian:12
- Versiones
- 3.4.1+dfsg-6
- 3.4.1+dfsg-6+deb12u1
- 3.4.1+dfsg-7
- 3.4.1+dfsg-8
- 3.4.1+dfsg-9
- 4.0.1+dfsg-1
- 4.0.1+dfsg-1~0exp2
- 4.0.1+dfsg-1~0exp3
- 4.0.1+dfsg-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
openslide Debian:13
- Versiones
- 3.4.1+dfsg-7
- 3.4.1+dfsg-7+deb13u1
- 3.4.1+dfsg-8
- 3.4.1+dfsg-9
- 4.0.1+dfsg-1
- 4.0.1+dfsg-1~0exp2
- 4.0.1+dfsg-1~0exp3
- 4.0.1+dfsg-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
openslide Debian:14
- Versiones
- 3.4.1+dfsg-7
- 3.4.1+dfsg-8
- 3.4.1+dfsg-9
- 4.0.1+dfsg-1~0exp2
- 4.0.1+dfsg-1~0exp3
- Intervalos de versiones afectados
- ECOSYSTEM: < 4.0.1+dfsg-1
Actualiza a 4.0.1+dfsg-1
openslide Ubuntu:16.04:LTS
- Versiones
- 3.4.0-1build1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
openslide Ubuntu:18.04:LTS
- Versiones
- 3.4.1+dfsg-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
openslide Ubuntu:20.04:LTS
- Versiones
- 3.4.1+dfsg-4
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
openslide Ubuntu:22.04:LTS
- Versiones
- 3.4.1+dfsg-5
- 3.4.1+dfsg-5build1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
openslide Ubuntu:24.04:LTS
- Versiones
- 3.4.1+dfsg-6build1
- 3.4.1+dfsg-7
- 3.4.1+dfsg-7build1
- 3.4.1+dfsg-7build2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
openslide Ubuntu:25.10
- Versiones
- 3.4.1+dfsg-7build2
- 3.4.1+dfsg-7build3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
openslide Ubuntu:26.10
- Versiones
- 3.4.1+dfsg-7build4
- 3.4.1+dfsg-9
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
openslide Ubuntu:26.04:LTS
- Versiones
- 3.4.1+dfsg-7build3
- 3.4.1+dfsg-7build4
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/openslide/openslide/security/advisories/GHSA-f734-jv98-5677
- https://github.com/openslide/openslide-bin/issues/433
- https://github.com/openslide/openslide-bin/pull/436
- https://github.com/openslide/openslide/pull/706
- https://github.com/openslide/openslide/commit/a4f0fb0ec462edcea97ff22288f606ac6cd370f5
- https://github.com/openslide/openslide/releases/tag/v4.0.1
- https://gitlab.com/libtiff/libtiff/-/work_items/791
- https://nvd.nist.gov/vuln/detail/CVE-2026-54604