CVE-2026-54654
CVE-2026-54654 · `datamodel-code-generator` vulnerable to code injection via unescaped carriage return in `--extra-template-data` `comment` field
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
datamodel-code-generator generates Python data models from schema definitions. From 0.14.1 until 0.60.2, the --extra-template-data comment field is rendered into Python comments in src/datamodel_code_generator/model/template/TypeAliasAnnotation.jinja2, src/datamodel_code_generator/model/template/TypedDict.jinja2, src/datamodel_code_generator/model/template/dataclass.jinja2, src/datamodel_code_generator/model/template/msgspec.Struct.jinja2, src/datamodel_code_generator/model/template/pydantic/BaseModel.jinja2, and src/datamodel_code_generator/model/template/pydantic_v2/BaseModel.jinja2 without neutralizing carriage returns in Python # comments, allowing an attacker-controlled comment value to inject Python code into generated models that runs when imported. This issue is fixed in version 0.60.2.
CVSS 7.8 · Alta · EPSS 0,2% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: python
Productos y versiones afectados
datamodel-code-generator
- Versiones
- >= 0.14.1, < 0.60.2: Afectada
Sin corrección publicada
datamodel-code-generator PyPI
- Versiones
- 0.14.1
- 0.15.0
- 0.16.0
- 0.16.1
- 0.17.0
- 0.17.1
- 0.17.2
- 0.18.0
- 0.18.1
- 0.19.0
- 0.20.0
- 0.21.0
- 0.21.1
- 0.21.2
- 0.21.3
- 0.21.4
- 0.21.5
- 0.22.0
- 0.22.1
- 0.23.0
- 0.24.0
- 0.24.1
- 0.24.2
- 0.25.0
- 0.25.1
- 0.25.2
- 0.25.3
- 0.25.4
- 0.25.5
- 0.25.6
- 0.25.7
- 0.25.8
- 0.25.9
- 0.26.0
- 0.26.1
- 0.26.2
- 0.26.3
- 0.26.4
- 0.26.5
- 0.27.0
- 0.27.1
- 0.27.2
- 0.27.3
- 0.28.0
- 0.28.1
- 0.28.2
- 0.28.3
- 0.28.4
- 0.28.5
- 0.29.0
- 0.30.0
- 0.30.1
- 0.30.2
- 0.31.0
- 0.31.1
- 0.31.2
- 0.32.0
- 0.33.0
- 0.34.0
- 0.35.0
- 0.36.0
- 0.37.0
- 0.38.0
- 0.39.0
- 0.40.0
- 0.41.0
- 0.42.0
- 0.42.1
- 0.42.2
- 0.43.0
- 0.43.1
- 0.44.0
- 0.45.0
- 0.46.0
- 0.47.0
- 0.48.0
- 0.49.0
- 0.50.0
- 0.51.0
- 0.52.0
- 0.52.1
- 0.52.2
- 0.53.0
- 0.54.0
- 0.54.1
- 0.55.0
- 0.56.0
- 0.56.1
- 0.57.0
- 0.58.0
- 0.59.0
- 0.59.1
- 0.60.0
- 0.60.1
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 0.14.1, < 0.60.2
Actualiza a 0.60.2
Fuentes originales
- https://github.com/koxudaxi/datamodel-code-generator/security/advisories/GHSA-wjv6-jcfj-mf9r
- https://github.com/koxudaxi/datamodel-code-generator/commit/b73abb5cd703a50471b8950bbd3bd0b82ad71de7
- https://github.com/koxudaxi/datamodel-code-generator/releases/tag/0.60.2
- https://nvd.nist.gov/vuln/detail/CVE-2026-54654