p PatchFirst

CVE-2026-54875

CVE-2026-54875 · Non-Constant-Time SM2 Scalar Multiplication on ARM64 and RISC-V

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Issue summary: A non-constant-time optimized implementation of scalar point multiplication is used for SM2 private key operations on ARM64 and RISC-V platforms. Impact summary: An attacker able to measure the time taken by, or to observe the cache-line access pattern of SM2 signing or decryption on an affected platform can learn information about the secret scalar. CWE: CWE-208: Observable Timing Discrepancy Description: On ARM64 and RISC-V processors, the SM2 curve uses an optimized scalar multiplication implementation whose conditional branches and table look ups are chosen according to the bits of the secret scalar. The execution time and the cache-access pattern therefore depend on the long-term private key (during SM2 decryption) or the per-signature nonce (during SM2 signature generation), forming a timing and cache side-channel. FIPS Impact: no SM2 is not a FIPS algorithm and the optimized SM2 implementation is not part of the FIPS module. OpenSSL 4.0, 3.6, 3.5 and 3.4 are vulnerable to this issue on AArch64 and RISC-V. OpenSSL 3.0, 1.1.1 and 1.0.2 are not affected by this issue. OpenSSL 4.0 users should upgrade to OpenSSL 4.0.3. OpenSSL 3.6 users should upgrade to OpenSSL 3.6.5. OpenSSL 3.5 users should upgrade to OpenSSL 3.5.9. OpenSSL 3.4 users should upgrade to OpenSSL 3.4.8. This issue was reported on 2 May 2026 by Abhinav Agarwal. It was independently reported on 6 June 2026 by Feng Xue. The fix was developed by Igor Ustinov. -- cut (non-publishing metadata for internal use) -- Reported by: Abhinav Agarwal, Feng Xue Fixed by: Igor Ustinov

CVSS 3.7 · Baja · EPSS 0,5% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · network

Productos y versiones afectados

  • openssl

    Versiones
    • ≥ 4.0.0, < 4.0.3: Afectada (semver)
    • ≥ 3.6.0, < 3.6.5: Afectada (semver)
    • ≥ 3.5.0, < 3.5.9: Afectada (semver)
    • ≥ 3.4.0, < 3.4.8: Afectada (semver)

    Actualiza a 3.4.8; Actualiza a 3.5.9; Actualiza a 3.6.5; Actualiza a 4.0.3

  • openssl Debian:13

    Versiones
    • 3.5.1-1
    • 3.5.1-1+deb13u1
    • 3.5.2-1
    • 3.5.3-1
    • 3.5.4-1
    • 3.5.4-1~deb13u1
    • 3.5.4-1~deb13u2
    • 3.5.5-1
    • 3.5.5-1~deb13u1
    • 3.5.5-1~deb13u2
    • 3.5.6-1~deb13u1
    • 3.5.6-1~deb13u2
    • 3.5.7-1~deb13u1
    • 3.5.7-1~deb13u2
    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.5.7-1~deb13u3

    Actualiza a 3.5.7-1~deb13u3

  • openssl Debian:14

    Versiones
    • 3.5.1-1
    • 3.5.2-1
    • 3.5.3-1
    • 3.5.4-1
    • 3.5.4-1~deb13u1
    • 3.5.4-1~deb13u2
    • 3.5.5-1
    • 3.5.5-1~deb13u1
    • 3.5.5-1~deb13u2
    • 3.5.6-1~deb13u1
    • 3.5.6-1~deb13u2
    • 3.5.7-1~deb13u1
    • 3.5.7-1~deb13u2
    • 3.5.7-1~deb13u3
    • 3.6.0-1
    • 3.6.0-2
    • 3.6.0~~alpha1-1
    • 3.6.0~~beta1-1
    • 3.6.1-1
    • 3.6.1-2
    • 3.6.1-3
    • 3.6.2-1
    • 3.6.3-1
    • 3.6.4-1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.6.5-1

    Actualiza a 3.6.5-1

  • nodejs Ubuntu:Pro:22.04:LTS

    Versiones
    • 12.22.5~dfsg-5ubuntu1
    • 12.22.7~dfsg-2ubuntu1
    • 12.22.7~dfsg-2ubuntu3
    • 12.22.9~dfsg-1ubuntu2
    • 12.22.9~dfsg-1ubuntu3
    • 12.22.9~dfsg-1ubuntu3.1
    • 12.22.9~dfsg-1ubuntu3.2
    • 12.22.9~dfsg-1ubuntu3.3
    • 12.22.9~dfsg-1ubuntu3.4
    • 12.22.9~dfsg-1ubuntu3.5
    • 12.22.9~dfsg-1ubuntu3.6
    • 12.22.9~dfsg-1ubuntu3.6+esm2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • edk2 Ubuntu:26.10

    Versiones
    • 2025.11-3ubuntu7
    • 2025.11-3ubuntu8
    • 2026.05-2ubuntu1
    • 2026.05-2ubuntu2
    • 2026.05-2ubuntu3
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • edk2-hwe Ubuntu:26.10

    Versiones
    • 2025.11-3ubuntu8
    • 2025.11-3ubuntu9
    • 2026.05-2ubuntu1
    • 2026.05-2ubuntu2
    • 2026.05-2ubuntu3
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • edk2 Ubuntu:26.04:LTS

    Versiones
    • 2025.02-8ubuntu3
    • 2025.11-3ubuntu6
    • 2025.11-3ubuntu7
    • 2025.11-3ubuntu7.2
    • 2025.11-3ubuntu7.3
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • edk2-hwe Ubuntu:26.04:LTS

    Versiones
    • 2025.11-3ubuntu6
    • 2025.11-3ubuntu8
    • 2025.11-3ubuntu8.2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • openssl Ubuntu:26.04:LTS

    Versiones
    • 3.5.3-1ubuntu2
    • 3.5.5-1ubuntu1
    • 3.5.5-1ubuntu3
    • 3.5.5-1ubuntu3.2
    • 3.5.5-1ubuntu3.3
    • 3.5.5-1ubuntu3.4
    • 3.5.5-1ubuntu3.5
    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.5.5-1ubuntu3.6

    Actualiza a 3.5.5-1ubuntu3.6

Fuentes originales

Comprueba tu servidor →