CVE-2026-55071
CVE-2026-55071 · MCP-for-Stata: Stata Command Injection via Unsanitized `package` in `ado_package_install`
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
MCP-for-Stata is a MCP server for integrating Stata into agent loops with a safety-first design. Prior to version 1.19.0, the ado_package_install MCP tool in stata-mcp concatenates user-controlled input directly into a Stata command string without any validation or sanitization. An attacker who can invoke the MCP tool or the equivalent Python API can embed newline characters in the package argument to inject arbitrary Stata commands. Because Stata supports a shell escape command, this leads to full OS-level arbitrary command execution (RCE) under the account running the Stata-MCP server. The tool is registered in the default all profile, so no non-default configuration is required. This issue has been patched in version 1.19.0.
CVSS 8.4 · Alta · EPSS 0,3% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: python
Productos y versiones afectados
mcp-for-stata
- Versiones
- < 1.19.0: Afectada
Sin corrección publicada
stata-mcp PyPI
- Versiones
- 0.1.0
- 1.10.0
- 1.10.1
- 1.10.2
- 1.11.0
- 1.11.1
- 1.12.0
- 1.12.1
- 1.13.0
- 1.13.1
- 1.13.10
- 1.13.11
- 1.13.12
- 1.13.13
- 1.13.14
- 1.13.15
- 1.13.16
- 1.13.17
- 1.13.18
- 1.13.19
- 1.13.2
- 1.13.20
- 1.13.21
- 1.13.22
- 1.13.23
- 1.13.24
- 1.13.25
- 1.13.26
- 1.13.27
- 1.13.28
- 1.13.29
- 1.13.3
- 1.13.30
- 1.13.31
- 1.13.32
- 1.13.33
- 1.13.34
- 1.13.35
- 1.13.36
- 1.13.37
- 1.13.38
- 1.13.39
- 1.13.4
- 1.13.40
- 1.13.41
- 1.13.42
- 1.13.5
- 1.13.6
- 1.13.7
- 1.13.8
- 1.13.9
- 1.14.0
- 1.14.1
- 1.14.2
- 1.14.3
- 1.15.0
- 1.15.1
- 1.16.0
- 1.16.1
- 1.16.2
- 1.16.3
- 1.17.0
- 1.17.1
- 1.17.2
- 1.17.3
- 1.18.0
- 1.18.1
- 1.18.2
- 1.3.10
- 1.3.2
- 1.3.3
- 1.3.4
- 1.3.5
- 1.3.6
- 1.3.7
- 1.3.8
- 1.4.0
- 1.4.1
- 1.5.1
- 1.5.2
- 1.5.3
- 1.6.0
- 1.6.1
- 1.6.2
- 1.6.3
- 1.7.0
- 1.7.1
- 1.7.2
- 1.7.3
- 1.7.4
- 1.8.0
- 1.8.1
- 1.8.2
- 1.9.0
- 1.9.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 1.19.0
Actualiza a 1.19.0