CVE-2026-55568
CVE-2026-55568 · Guzzle: Silent HTTPS-Proxy Downgrade to Cleartext
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Guzzle is an extensible PHP HTTP client. Prior to 7.12.1, in certain configurations, traffic expected to be protected by TLS on the hop to the proxy is transmitted in cleartext. Proxy authentication credentials (the Proxy-Authorization header, proxy userinfo in the proxy URL, or CURLOPT_PROXYUSERPWD) are sent without encryption, and the CONNECT target host and port for tunneled HTTPS requests are exposed. The built-in cURL handlers (GuzzleHttp\Handler\CurlHandler and GuzzleHttp\Handler\CurlMultiHandler, used by default whenever the PHP cURL extension is available) accept an https:// proxy. libcurl older than 7.50.2 silently treats an https:// proxy as a plaintext http:// proxy. The TLS connection to the proxy is never established, and the proxy leg is cleartext with no error or warning. An application is affected when it sends requests through one of the built-in cURL handlers, configures an https:// proxy expecting the proxy connection itself to be encrypted, and runs with libcurl older than 7.50.2. This vulnerability is fixed in 7.12.1.
CVSS 5.9 · Media · EPSS 0,1% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · php
Productos y versiones afectados
guzzle
- Versiones
- < 7.12.1: Afectada
Sin corrección publicada
guzzle Debian:12
- Versiones
- 7.11.0-1
- 7.12.0-1
- 7.12.1-1
- 7.12.3-1
- 7.13.1-1
- 7.14.0-1
- 7.14.1-1
- 7.14.2-1
- 7.15.0-1
- 7.15.1-1
- 7.15.2-1
- 7.15.3-1
- 7.15.5-1
- 7.4.5-1
- 7.9.2-0.1
- 8.0.1-1
- 8.0.2-1
- 8.1.0-1
- 8.2.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
guzzle Debian:13
- Versiones
- 7.11.0-1
- 7.12.0-1
- 7.12.1-1
- 7.12.3-1
- 7.13.1-1
- 7.14.0-1
- 7.14.1-1
- 7.14.2-1
- 7.15.0-1
- 7.15.1-1
- 7.15.2-1
- 7.15.3-1
- 7.15.5-1
- 7.9.2-0.1
- 8.0.1-1
- 8.0.2-1
- 8.1.0-1
- 8.2.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
guzzle Debian:14
- Versiones
- 7.11.0-1
- 7.12.0-1
- 7.9.2-0.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 7.12.1-1
Actualiza a 7.12.1-1
guzzlehttp/guzzle Packagist
- Versiones
- 4.0.0
- 4.0.0-rc.1
- 4.0.0-rc.2
- 4.0.1
- 4.0.2
- 4.1.0
- 4.1.1
- 4.1.2
- 4.1.3
- 4.1.4
- 4.1.5
- 4.1.6
- 4.1.7
- 4.1.8
- 4.2.0
- 4.2.1
- 4.2.2
- 4.2.3
- 4.2.4
- 5.0.0
- 5.0.1
- 5.0.2
- 5.0.3
- 5.1.0
- 5.2.0
- 5.3.0
- 5.3.1
- 5.3.2
- 5.3.3
- 5.3.4
- 6.0.0
- 6.0.1
- 6.0.2
- 6.1.0
- 6.1.1
- 6.2.0
- 6.2.1
- 6.2.2
- 6.2.3
- 6.3.0
- 6.3.1
- 6.3.2
- 6.3.3
- 6.4.0
- 6.4.1
- 6.5.0
- 6.5.1
- 6.5.2
- 6.5.3
- 6.5.4
- 6.5.5
- 6.5.6
- 6.5.7
- 6.5.8
- 7.0.0
- 7.0.0-beta.1
- 7.0.0-beta.2
- 7.0.0-rc.1
- 7.0.1
- 7.1.0
- 7.1.1
- 7.10.0
- 7.10.1
- 7.10.2
- 7.10.3
- 7.10.4
- 7.10.5
- 7.10.6
- 7.11.0
- 7.11.1
- 7.11.2
- 7.12.0
- 7.2.0
- 7.3.0
- 7.4.0
- 7.4.1
- 7.4.2
- 7.4.3
- 7.4.4
- 7.4.5
- 7.5.0
- 7.5.1
- 7.5.2
- 7.5.3
- 7.6.0
- 7.6.1
- 7.7.0
- 7.7.1
- 7.8.0
- 7.8.1
- 7.8.2
- 7.9.0
- 7.9.1
- 7.9.2
- 7.9.3
- v1.0.3
- v1.0.4
- v2.0.0
- v2.0.1
- v2.0.2
- v2.0.3
- v2.0.4
- v2.0.5
- v2.1.0
- v2.1.1
- v2.1.2
- v2.1.3
- v2.1.4
- v2.2.0
- v2.2.1
- v2.2.2
- v2.2.3
- v2.2.4
- v2.3.2
- v2.4.0
- v2.4.1
- v2.5.0
- v2.6.0
- v2.6.1
- v2.6.2
- v2.6.3
- v2.6.4
- v2.6.5
- v2.6.6
- v2.7.0
- v2.7.1
- v2.7.2
- v2.8.0
- v2.8.1
- v2.8.2
- v2.8.3
- v2.8.4
- v2.8.5
- v2.8.6
- v2.8.7
- v2.8.8
- v3.0.0
- v3.0.1
- v3.0.2
- v3.0.3
- v3.0.4
- v3.0.5
- v3.0.6
- v3.0.7
- v3.1.0
- v3.1.1
- v3.1.2
- v3.2.0
- v3.3.0
- v3.3.1
- v3.4.0
- v3.4.1
- v3.4.2
- v3.4.3
- v3.5.0
- v3.6.0
- v3.7.0
- v3.7.1
- v3.7.2
- v3.7.3
- v3.7.4
- v3.8.0
- v3.8.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 7.12.1
Actualiza a 7.12.1
guzzle Ubuntu:24.04:LTS
- Versiones
- 7.4.5-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
guzzle Ubuntu:25.10
- Versiones
- 7.9.2-0.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
guzzle Ubuntu:26.10
- Versiones
- 7.9.2-0.1build1
- 7.13.1-1
- 7.15.1-1
- 7.15.2-1
- 7.15.3-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
guzzle Ubuntu:26.04:LTS
- Versiones
- 7.9.2-0.1
- 7.9.2-0.1build1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada