p PatchFirst

CVE-2026-55640

CVE-2026-55640 · Nextcloud MCP Server: Unauthenticated `POST /webhooks/nextcloud` allows arbitrary vector data deletion when `WEBHOOK_SECRET` is unset ( default )

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Nextcloud MCP Server is a production-ready MCP server that connects AI assistants to a Nextcloud instance. Prior to 0.117.2, the POST /webhooks/nextcloud endpoint in nextcloud_mcp_server/vector/webhook_receiver.py has no authentication by default because WEBHOOK_SECRET defaults to None and startup validation does not require it. When WEBHOOK_SECRET is unset, handle_nextcloud_webhook() accepts unauthenticated requests. The payload["user"]["uid"] field parsed in nextcloud_mcp_server/vector/webhook_parser.py is attacker-controlled and is used without an authenticated-session cross-check for Qdrant operations, allowing a network attacker to delete or trigger re-indexing of vector embeddings for any user and to destroy the semantic search index by sending forged deletion events. This issue is fixed in version 0.117.2.

CVSS 9.1 · Crítica · EPSS 0,7% · Corrección disponible

Publicación
Actualización

Pila tecnológica: python

Productos y versiones afectados

  • nextcloud-mcp-server

    Versiones
    • < 0.117.2: Afectada

    Sin corrección publicada

  • nextcloud-mcp-server PyPI

    Versiones
    • 0.100.0
    • 0.101.0
    • 0.101.1
    • 0.101.2
    • 0.101.3
    • 0.101.4
    • 0.102.0
    • 0.103.0
    • 0.104.0
    • 0.104.1
    • 0.105.0
    • 0.106.0
    • 0.107.0
    • 0.108.0
    • 0.108.1
    • 0.108.2
    • 0.108.3
    • 0.109.0
    • 0.109.1
    • 0.110.0
    • 0.110.1
    • 0.110.2
    • 0.111.0
    • 0.112.0
    • 0.113.0
    • 0.113.1
    • 0.114.0
    • 0.115.0
    • 0.115.1
    • 0.116.0
    • 0.117.0
    • 0.117.1
    • 0.17.1
    • 0.65.3
    • 0.65.4
    • 0.66.0
    • 0.66.1
    • 0.66.2
    • 0.67.0
    • 0.68.0
    • 0.68.1
    • 0.68.2
    • 0.68.3
    • 0.68.4
    • 0.69.0
    • 0.70.0
    • 0.70.1
    • 0.70.2
    • 0.70.3
    • 0.70.4
    • 0.71.0
    • 0.72.0
    • 0.72.1
    • 0.72.2
    • 0.72.3
    • 0.72.4
    • 0.72.5
    • 0.72.6
    • 0.72.7
    • 0.73.0
    • 0.73.1
    • 0.73.2
    • 0.74.0
    • 0.75.0
    • 0.75.1
    • 0.75.2
    • 0.76.0
    • 0.77.0
    • 0.77.1
    • 0.78.0
    • 0.79.0
    • 0.79.1
    • 0.79.2
    • 0.79.3
    • 0.80.0
    • 0.81.0
    • 0.82.0
    • 0.83.0
    • 0.83.1
    • 0.83.2
    • 0.83.3
    • 0.83.4
    • 0.84.0
    • 0.84.1
    • 0.84.2
    • 0.85.0
    • 0.85.1
    • 0.86.0
    • 0.86.1
    • 0.86.2
    • 0.86.3
    • 0.86.4
    • 0.87.0
    • 0.87.1
    • 0.87.2
    • 0.88.0
    • 0.88.1
    • 0.88.2
    • 0.88.3
    • 0.89.0
    • 0.90.0
    • 0.90.1
    • 0.90.2
    • 0.91.0
    • 0.91.1
    • 0.91.2
    • 0.91.3
    • 0.92.0
    • 0.92.1
    • 0.93.0
    • 0.94.0
    • 0.94.1
    • 0.95.0
    • 0.96.0
    • 0.97.0
    • 0.98.0
    • 0.98.1
    • 0.99.0
    Intervalos de versiones afectados
    • ECOSYSTEM: < 0.117.2

    Actualiza a 0.117.2

Fuentes originales

Comprueba tu servidor →