CVE-2026-56684
CVE-2026-56684 · Valkey: TLS pending-data processing use-after-free may allow remote code execution
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Valkey is a distributed key-value database. Prior to 7.2.14, 8.0.10, 8.1.9, 9.0.5, and 9.1.1, Valkey's tlsProcessPendingData function iterates pending_list while an authenticated client can trigger CLIENT KILL, causing connTLSClose to delete the iterator's cached next node and producing a use-after-free that can crash the server or potentially allow remote code execution when TLS is enabled. This issue is fixed in versions 7.2.14, 8.0.10, 8.1.9, 9.0.5, and 9.1.1.
CVSS 7.5 · Alta · EPSS 0,9% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · database
Productos y versiones afectados
valkey
- Versiones
- < 7.2.14: Afectada
- >= 8.0.0, < 8.0.10: Afectada
- >= 8.1.0, < 8.1.9: Afectada
- >= 9.0.0, < 9.0.5: Afectada
- >= 9.1.0, < 9.1.1: Afectada
Sin corrección publicada
redict Debian:14
- Versiones
- 7.3.0+ds-1
- 7.3.0+ds-2
- 7.3.0+ds-3
- 7.3.0+ds-3~bpo12+1
- 7.3.1+ds-1
- 7.3.2+ds-1
- 7.3.2+ds-1~bpo12+1
- 7.3.5+ds-1
- 7.3.5+ds-1~bpo12+1
- 7.3.6+ds-1
- 7.3.6+ds-1~bpo12+1
- 7.3.6+ds-1~bpo13+1
- 7.3.6+ds-2
- 7.3.6+ds-2~bpo12+1
- 7.3.6+ds-2~bpo13+1
- 7.3.6+ds-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
valkey Debian:13
- Versiones
- 8.1.1+dfsg1-3
- 8.1.1+dfsg1-3+deb13u1
- 8.1.1+dfsg1-3+deb13u2
- Intervalos de versiones afectados
- ECOSYSTEM: < 8.1.1+dfsg1-3+deb13u3
Actualiza a 8.1.1+dfsg1-3+deb13u3
valkey Debian:14
- Versiones
- 8.1.1+dfsg1-3
- 8.1.4+dfsg1-1
- 8.1.4+dfsg1-2
- Intervalos de versiones afectados
- ECOSYSTEM: < 9.1.1-1
Actualiza a 9.1.1-1
valkey Ubuntu:Pro:24.04:LTS
- Versiones
- 7.2.5+dfsg1-2ubuntu4~24.04.1
- 7.2.7+dfsg1-0ubuntu0.24.04.1
- 7.2.8+dfsg1-0ubuntu0.24.04.1
- 7.2.8+dfsg1-0ubuntu0.24.04.2
- 7.2.8+dfsg1-0ubuntu0.24.04.3
- 7.2.10+dfsg1-0ubuntu0.1
- 7.2.11+dfsg1-0ubuntu0.1
- 7.2.11+dfsg1-0ubuntu0.2
- 7.2.12+dfsg1-0ubuntu0.1
- 7.2.13+dfsg1-0ubuntu0.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 7.2.13+dfsg1-0ubuntu0.1+esm1
Actualiza a 7.2.13+dfsg1-0ubuntu0.1+esm1
valkey Ubuntu:26.04:LTS
- Versiones
- 8.1.3+dfsg1-0ubuntu2
- 8.1.4+dfsg1-0ubuntu1
- 9.0.2-0ubuntu1
- 9.0.3-0ubuntu1
- 9.0.3-0ubuntu2
- 9.0.4-0ubuntu0.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 9.0.4-0ubuntu0.2
Actualiza a 9.0.4-0ubuntu0.2
Fuentes originales
- https://github.com/valkey-io/valkey/security/advisories/GHSA-53mc-f3m3-99vh
- https://github.com/valkey-io/valkey/pull/4234
- https://github.com/valkey-io/valkey/commit/7cd5bcb7575d750ec2de618db80da58680a10fe3
- https://github.com/valkey-io/valkey/releases/tag/7.2.14
- https://github.com/valkey-io/valkey/releases/tag/8.0.10
- https://github.com/valkey-io/valkey/releases/tag/8.1.9
- https://github.com/valkey-io/valkey/releases/tag/9.0.5
- https://github.com/valkey-io/valkey/releases/tag/9.1.1
- https://nvd.nist.gov/vuln/detail/CVE-2026-56684