CVE-2026-56722
CVE-2026-56722 · Dompdf: Local file read due to improper file path validation in SVG images encoded as data-URI
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Dompdf is an HTML to PDF converter for PHP. In versions 3.15 and prior, aAn attacker who controls the HTML input can bypass this restriction by embedding a target file path inside an SVG image delivered through a data: URI, because dompdf processes the SVG twice and the second pass does not enforce the same protections as the first. When rendering, dompdf hands the SVG to the separate php-svg-lib library with external references forced on, and that library has no knowledge of the chroot directory, blocks only the phar:// scheme, and ultimately reads the referenced file with no path or protocol validation. This lets an external, unauthenticated attacker read arbitrary image files from the server's file system in the default configuration. This issue has been fixed in version 3.16.
CVSS 6.3 · Media · EPSS 0,4% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · php
Productos y versiones afectados
dompdf
- Versiones
- < 3.1.6: Afectada
Sin corrección publicada
php-dompdf Debian:12
- Versiones
- 2.0.3+dfsg-1
- 2.0.3+dfsg-1+deb12u1
- 2.0.3+dfsg-2
- 2.0.3+dfsg-3
- 2.0.3+dfsg-4
- 2.0.4+dfsg-1
- 2.0.4+dfsg-2
- 2.0.7+dfsg-1
- 3.0.0+dfsg-1
- 3.0.0+dfsg-2
- 3.0.1+dfsg-1
- 3.0.2+dfsg-1
- 3.1.0+dfsg-1
- 3.1.4+dfsg-1
- 3.1.4+dfsg-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
dompdf/dompdf Packagist
- Versiones
- v0.6.0
- v0.6.1
- v0.6.2
- v0.7.0
- v0.7.0-beta
- v0.7.0-beta2
- v0.7.0-beta3
- v0.8.0
- v0.8.1
- v0.8.2
- v0.8.3
- v0.8.4
- v0.8.5
- v0.8.6
- v1.0.0
- v1.0.1
- v1.0.2
- v1.1.0
- v1.1.1
- v1.2.0
- v1.2.1
- v1.2.2
- v2.0.0
- v2.0.1
- v2.0.2
- v2.0.3
- v2.0.4
- v2.0.5
- v2.0.7
- v2.0.8
- v3.0.0
- v3.0.1
- v3.0.2
- v3.1.0
- v3.1.1
- v3.1.2
- v3.1.3
- v3.1.4
- v3.1.5
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.1.6
Actualiza a 3.1.6
php-dompdf Ubuntu:Pro:16.04:LTS
- Versiones
- 0.6.1+dfsg-2
- 0.6.1+dfsg-2build1
- 0.6.1+dfsg-2ubuntu1
- 0.6.1+dfsg-2ubuntu1+esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
php-dompdf Ubuntu:Pro:18.04:LTS
- Versiones
- 0.6.2+dfsg-3
- 0.6.2+dfsg-3ubuntu0.18.04.1~esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
php-dompdf Ubuntu:20.04:LTS
- Versiones
- 0.6.2+dfsg-3
- 0.6.2+dfsg-3ubuntu0.20.04.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
php-dompdf Ubuntu:22.04:LTS
- Versiones
- 0.6.2+dfsg-3.1
- 0.6.2+dfsg-3.1ubuntu0.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/dompdf/dompdf/security/advisories/GHSA-cx96-42px-69fm
- https://github.com/dompdf/dompdf/commit/6a58996865db05d8fede748507e50ac4b8c5bfd0
- https://github.com/dompdf/dompdf/commit/bf7b02f642e26007dedc5a22b3d6e15f9931120a
- https://github.com/dompdf/dompdf/releases/tag/v3.1.6
- https://nvd.nist.gov/vuln/detail/CVE-2026-56722