CVE-2026-56737
CVE-2026-56737 · phpMyFAQ's two-factor authentication login bypasses the password factor
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
phpMyFAQ is an open source FAQ web application. Versions 3.2.0 through 4.1.5 contain an authentication bypass in its public two-factor authentication verification flow: an unauthenticated attacker can submit an account’s numeric user ID and a valid or brute-forced six-digit TOTP code without first authenticating with the account password, allowing takeover of any 2FA-enabled account, including administrator accounts. Version 4.1.6 is patched by binding TOTP verification to a session established after successful password authentication and limiting failed TOTP attempts. No official workaround is documented; affected installations should upgrade to 4.1.6 or later.
CVSS 8.1 · Alta · EPSS 0,5% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: php
Productos y versiones afectados
phpmyfaq
- Versiones
- >= 3.2.0, < 4.1.6: Afectada
Sin corrección publicada
thorsten/phpmyfaq Packagist
- Versiones
- 3.2.0
- 3.2.1
- 3.2.10
- 3.2.2
- 3.2.3
- 3.2.4
- 3.2.5
- 3.2.6
- 3.2.7
- 3.2.8
- 3.2.9
- 4.0.0
- 4.0.0-RC
- 4.0.0-RC.2
- 4.0.0-RC.3
- 4.0.0-RC.4
- 4.0.0-RC.5
- 4.0.0-alpha
- 4.0.0-alpha.2
- 4.0.0-alpha.3
- 4.0.0-alpha.4
- 4.0.0-beta
- 4.0.0-beta.2
- 4.0.1
- 4.0.10
- 4.0.11
- 4.0.12
- 4.0.13
- 4.0.14
- 4.0.15
- 4.0.16
- 4.0.18
- 4.0.19
- 4.0.2
- 4.0.3
- 4.0.4
- 4.0.5
- 4.0.6
- 4.0.7
- 4.0.8
- 4.0.9
- 4.1.0
- 4.1.0-RC
- 4.1.0-RC.2
- 4.1.0-RC.4
- 4.1.0-RC.5
- 4.1.0-RC.6
- 4.1.0-RC.7
- 4.1.0-alpha
- 4.1.0-alpha.2
- 4.1.0-alpha.3
- 4.1.0-beta
- 4.1.0-beta.2
- 4.1.1
- 4.1.2
- 4.1.3
- 4.1.4
- 4.1.5
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 3.2.0, < 4.1.6
Actualiza a 4.1.6
phpmyfaq/phpmyfaq Packagist
- Versiones
- 3.2.0
- 3.2.1
- 3.2.10
- 3.2.2
- 3.2.3
- 3.2.4
- 3.2.5
- 3.2.6
- 3.2.7
- 3.2.8
- 3.2.9
- 4.0.0
- 4.0.0-RC
- 4.0.0-RC.2
- 4.0.0-RC.3
- 4.0.0-RC.4
- 4.0.0-RC.5
- 4.0.0-alpha
- 4.0.0-alpha.2
- 4.0.0-alpha.3
- 4.0.0-alpha.4
- 4.0.0-beta
- 4.0.0-beta.2
- 4.0.1
- 4.0.10
- 4.0.11
- 4.0.12
- 4.0.13
- 4.0.14
- 4.0.15
- 4.0.16
- 4.0.18
- 4.0.19
- 4.0.2
- 4.0.3
- 4.0.4
- 4.0.5
- 4.0.6
- 4.0.7
- 4.0.8
- 4.0.9
- 4.1.0
- 4.1.0-RC
- 4.1.0-RC.2
- 4.1.0-RC.4
- 4.1.0-RC.5
- 4.1.0-RC.6
- 4.1.0-RC.7
- 4.1.0-alpha
- 4.1.0-alpha.2
- 4.1.0-alpha.3
- 4.1.0-beta
- 4.1.0-beta.2
- 4.1.1
- 4.1.2
- 4.1.3
- 4.1.4
- 4.1.5
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 3.2.0, < 4.1.6
Actualiza a 4.1.6
Fuentes originales
- https://github.com/thorsten/phpMyFAQ/security/advisories/GHSA-8gpw-xvpf-hvx5
- https://github.com/thorsten/phpMyFAQ/commit/410208b90f1d01534812ac5203d3e8d9c7bd591f
- https://github.com/thorsten/phpMyFAQ/commit/5097dff341fb01e93e8561e7261b3ae657df715a
- https://github.com/thorsten/phpMyFAQ/commit/6a69f6e2142fde722165c65b7e0a49f3176e87be
- https://nvd.nist.gov/vuln/detail/CVE-2026-56737