p PatchFirst

CVE-2026-56825

CVE-2026-56825 · Shopper: Missing authorization on product removal actions in CollectionProducts component

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Shopper is a Headless e-commerce Admin Panel. Prior to 2.9.2, packages/admin/src/Livewire/Components/Collection/CollectionProducts.php exposes Action::make('delete') and DeleteBulkAction::make() without delete_collections authorization, while public Collection $collection remains client mutable because it lacks the Livewire Locked attribute. An authenticated staff user with only browse_collections can invoke a Livewire removal action, substitute an arbitrary collection identifier, and detach selected products or empty the collection. This can disrupt catalog landing pages and promotions associated with the targeted collection. This issue is fixed in version 2.9.2.

CVSS 8.1 · Alta · EPSS 0,5% · Corrección disponible

Publicación
Actualización

Pila tecnológica: php

Productos y versiones afectados

  • shopper

    Versiones
    • < 2.9.2: Afectada

    Sin corrección publicada

  • shopper/framework Packagist

    Versiones
    • v2.0.0
    • v2.0.0-alpha
    • v2.0.0-beta
    • v2.0.0-beta10
    • v2.0.0-beta11
    • v2.0.0-beta12
    • v2.0.0-beta13
    • v2.0.0-beta14
    • v2.0.0-beta15
    • v2.0.0-beta16
    • v2.0.0-beta17
    • v2.0.0-beta18
    • v2.0.0-beta19
    • v2.0.0-beta2
    • v2.0.0-beta20
    • v2.0.0-beta21
    • v2.0.0-beta3
    • v2.0.0-beta4
    • v2.0.0-beta5
    • v2.0.0-beta6
    • v2.0.0-beta7
    • v2.0.0-beta8
    • v2.0.0-beta9
    • v2.0.1
    • v2.0.2
    • v2.0.3
    • v2.1.1
    • v2.1.2
    • v2.1.3
    • v2.1.4
    • v2.1.5
    • v2.1.6
    • v2.2
    • v2.2.1
    • v2.2.2
    • v2.2.3
    • v2.2.4
    • v2.2.5
    • v2.2.6
    • v2.2.7
    • v2.3
    • v2.3.1
    • v2.3.2
    • v2.3.3
    • v2.4.0
    • v2.4.1
    • v2.4.2
    • v2.4.3
    • v2.5.0
    • v2.5.1
    • v2.6.0
    • v2.6.1
    • v2.6.2
    • v2.6.3
    • v2.6.4
    • v2.7.0
    • v2.7.1
    • v2.7.2
    • v2.7.3
    • v2.8.0
    • v2.8.1
    • v2.9.0
    • v2.9.1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 2.9.2

    Actualiza a 2.9.2

Fuentes originales

Comprueba tu servidor →