p PatchFirst

CVE-2026-58162

CVE-2026-58162 · Apache Traffic Server: Certifier plugin trusts client SNI when generating certificates

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

The Apache Traffic Server certifier plugin generates certificates based on attacker-controlled client SNI. This issue affects Apache Traffic Server: from 8.0.0 through 8.1.11, from 9.0.0 through 9.2.14, from 10.0.0 through 10.1.3. Users are recommended to upgrade to version 9.2.15 or 10.1.4, which fix the issue.

CVSS 8.4 · Alta · EPSS 0,4%

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • apache traffic server

    Versiones
    • ≥ 8.0.0, ≤ 8.1.11: Afectada (semver)
    • ≥ 9.0.0, ≤ 9.2.14: Afectada (semver)
    • ≥ 10.0.0, ≤ 10.1.3: Afectada (semver)

    Sin corrección publicada

  • trafficserver Debian:12

    Versiones
    • 9.2.0+ds-2
    • 9.2.0+ds-2+deb12u1
    • 9.2.1+ds-1
    • 9.2.2+ds-1
    • 9.2.3+ds-1
    • 9.2.3+ds-1+deb12u1
    • 9.2.4+ds-0+deb12u1
    • 9.2.4+ds-1
    • 9.2.4+ds-2
    • 9.2.5+ds-0+deb12u1
    • 9.2.5+ds-0+deb12u2
    • 9.2.5+ds-0+deb12u3
    • 9.2.5+ds-0+deb12u4
    • 9.2.5+ds-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • trafficserver Ubuntu:16.04:LTS

    Versiones
    • 5.3.0-2ubuntu1
    • 5.3.0-2ubuntu2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • trafficserver Ubuntu:18.04:LTS

    Versiones
    • 7.0.0-5
    • 7.1.2+ds-2
    • 7.1.2+ds-2build1
    • 7.1.2+ds-3
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • trafficserver Ubuntu:Pro:20.04:LTS

    Versiones
    • 8.0.5+ds-1
    • 8.0.5+ds-2
    • 8.0.5+ds-2build1
    • 8.0.5+ds-2ubuntu1
    • 8.0.5+ds-3
    • 8.0.5+ds-3ubuntu0.1~esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • trafficserver Ubuntu:Pro:22.04:LTS

    Versiones
    • 8.1.1+ds-1.1
    • 9.1.1+ds-2build1
    • 9.1.1+ds-2ubuntu0.1~esm1
    • 9.1.1+ds-2ubuntu0.1
    • 9.1.1+ds-2ubuntu0.1+esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • trafficserver Ubuntu:24.04:LTS

    Versiones
    • 9.2.1+ds-1build1
    • 9.2.2+ds-1
    • 9.2.3+ds-1
    • 9.2.3+ds-1+deb12u1
    • 9.2.3+ds-1+deb12u1build1
    • 9.2.3+ds-1+deb12u1build3
    • 9.2.3+ds-1+deb12u1build4
    • 9.2.3+ds-1+deb12u1ubuntu0.1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →