p PatchFirst

CVE-2026-59985

CVE-2026-59985 · OpenEXR: Heap out-of-bounds read in OpenEXRCore RLE decoding on ILP32

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

OpenEXR is the reference implementation and specification for the EXR image format, widely used in the motion picture industry. OpenEXR versions 3.2.0 through 3.2.10, 3.3.0 through 3.3.12, and 3.4.0 through 3.4.13 are vulnerable on ILP32 builds to a heap out-of-bounds read. The issue occurs when a crafted RLE-compressed EXR causes the 64-bit unpacked size to truncate before allocation in OpenEXRCore decoding.c and unpack_32bit() reads beyond the resulting buffer, allowing denial of service. This issue is fixed in versions 3.2.11, 3.3.13, and 3.4.14.

CVSS 5.5 · Media · EPSS 0,2% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • openexr

    Versiones
    • >= 3.2.0, < 3.2.11: Afectada
    • >= 3.3.0, < 3.3.13: Afectada
    • >= 3.4.0, < 3.4.14: Afectada

    Sin corrección publicada

  • openexr Debian:12

    Versiones
    • 3.1.13-1
    • 3.1.13-2
    • 3.1.5-5
    • 3.1.5-5.1
    • 3.1.5-5.1+hurd.1
    • 3.4.14-0.1
    • 3.4.15+ds-1
    • 3.4.6+ds-1
    • 3.4.6+ds-2
    • 3.4.6+ds-3
    • 3.4.6+ds-4
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • openexr Debian:13

    Versiones
    • 3.1.13-2
    • 3.4.14-0.1
    • 3.4.15+ds-1
    • 3.4.6+ds-1
    • 3.4.6+ds-2
    • 3.4.6+ds-3
    • 3.4.6+ds-4
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • openexr Debian:14

    Versiones
    • 3.1.13-2
    • 3.4.6+ds-1
    • 3.4.6+ds-2
    • 3.4.6+ds-3
    • 3.4.6+ds-4
    Intervalos de versiones afectados
    • ECOSYSTEM: < 3.4.14-0.1

    Actualiza a 3.4.14-0.1

  • openexr Ubuntu:Pro:16.04:LTS

    Versiones
    • 2.2.0-1ubuntu3
    • 2.2.0-7ubuntu1
    • 2.2.0-9ubuntu1
    • 2.2.0-10ubuntu2
    • 2.2.0-10ubuntu2.1
    • 2.2.0-10ubuntu2.2
    • 2.2.0-10ubuntu2.3
    • 2.2.0-10ubuntu2.4
    • 2.2.0-10ubuntu2.6
    • 2.2.0-10ubuntu2.6+esm1
    • 2.2.0-10ubuntu2.6+esm2
    • 2.2.0-10ubuntu2.6+esm3
    • 2.2.0-10ubuntu2.6+esm4
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • openexr Ubuntu:Pro:18.04:LTS

    Versiones
    • 2.2.0-11ubuntu1
    • 2.2.0-11.1ubuntu1
    • 2.2.0-11.1ubuntu1.1
    • 2.2.0-11.1ubuntu1.2
    • 2.2.0-11.1ubuntu1.3
    • 2.2.0-11.1ubuntu1.4
    • 2.2.0-11.1ubuntu1.6
    • 2.2.0-11.1ubuntu1.7
    • 2.2.0-11.1ubuntu1.8
    • 2.2.0-11.1ubuntu1.9
    • 2.2.0-11.1ubuntu1.9+esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • openexr Ubuntu:Pro:20.04:LTS

    Versiones
    • 2.2.1-4.1ubuntu1
    • 2.3.0-6
    • 2.3.0-6build1
    • 2.3.0-6ubuntu0.1
    • 2.3.0-6ubuntu0.2
    • 2.3.0-6ubuntu0.3
    • 2.3.0-6ubuntu0.5
    • 2.3.0-6ubuntu0.5+esm1
    • 2.3.0-6ubuntu0.5+esm2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • openexr Ubuntu:Pro:22.04:LTS

    Versiones
    • 2.5.4-2
    • 2.5.7-1
    • 2.5.7-1ubuntu0.1~esm1
    • 2.5.7-1ubuntu0.1~esm2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • openexr Ubuntu:Pro:24.04:LTS

    Versiones
    • 3.1.5-5.1
    • 3.1.5-5.1build1
    • 3.1.5-5.1build2
    • 3.1.5-5.1build3
    • 3.1.5-5.1ubuntu0.1~esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • openexr Ubuntu:26.10

    Versiones
    • 3.1.13-2build1
    • 3.4.6+ds-4ubuntu3
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • openexr Ubuntu:Pro:26.04:LTS

    Versiones
    • 3.1.13-2
    • 3.1.13-2build1
    • 3.1.13-2ubuntu0.26.04.1~esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →