CVE-2026-61714
CVE-2026-61714 · FluidSynth: Heap Buffer Overflow in MIDI Player
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
FluidSynth is a software synthesizer based on the SoundFont 2 specifications. From 2.2.4 until 2.5.6, configuring synth.midi-channels above 16 allows the MIDI player to index _fluid_player_t::channel_isplaying outside its fixed-size heap allocation while tracking active channels. The resulting out-of-bounds reads and writes invoke undefined behavior and may compromise confidentiality, integrity, or availability. No crafted MIDI file is required because the unsafe condition is created by the channel-count configuration itself. Keeping synth.midi-channels at its default value of 16 avoids the vulnerable path. This issue is fixed in version 2.5.6.
CVSS 7.8 · Alta · EPSS 0,1% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
fluidsynth
- Versiones
- >= 2.2.4, < 2.5.6: Afectada
Sin corrección publicada
fluidsynth Debian:12
- Versiones
- 2.3.1-2
- 2.3.2-1
- 2.3.3-1
- 2.3.3-2
- 2.3.3-2.1
- 2.3.4-1
- 2.3.5-1
- 2.3.6-1
- 2.4.0-1
- 2.4.0-1~hurd.1
- 2.4.0-1~hurd.2
- 2.4.2-1
- 2.4.3+dfsg-1
- 2.4.3+dfsg-2
- 2.4.3+dfsg-3
- 2.4.3+dfsg-4
- 2.4.3-1
- 2.4.4+dfsg-1
- 2.4.6+dfsg-1
- 2.4.7+dfsg-1
- 2.4.7+dfsg-2
- 2.4.8+dfsg-1
- 2.5.0+dfsg-1
- 2.5.1+dfsg-1
- 2.5.1+dfsg-2
- 2.5.2+dfsg-1
- 2.5.3+dfsg-1
- 2.5.4+dfsg-1
- 2.5.5+dfsg-1
- 2.5.5+dfsg-2
- 2.5.6+dfsg-1
- 2.5.7+dfsg-1
- 2.6.0+dfsg-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
fluidsynth Debian:13
- Versiones
- 2.4.4+dfsg-1
- 2.4.4+dfsg-1+deb13u1
- 2.4.4+dfsg-1+deb13u2
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.4.4+dfsg-1+deb13u3
Actualiza a 2.4.4+dfsg-1+deb13u3
fluidsynth Debian:14
- Versiones
- 2.4.4+dfsg-1
- 2.4.6+dfsg-1
- 2.4.7+dfsg-1
- 2.4.7+dfsg-2
- 2.4.8+dfsg-1
- 2.5.0+dfsg-1
- 2.5.1+dfsg-1
- 2.5.1+dfsg-2
- 2.5.2+dfsg-1
- 2.5.3+dfsg-1
- 2.5.4+dfsg-1
- 2.5.5+dfsg-1
- 2.5.5+dfsg-2
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.5.6+dfsg-1
Actualiza a 2.5.6+dfsg-1
fluidsynth Ubuntu:Pro:22.04:LTS
- Versiones
- 2.1.7-1.1
- 2.2.4-2
- 2.2.5-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.2.5-1ubuntu0.1~esm1
Actualiza a 2.2.5-1ubuntu0.1~esm1
fluidsynth Ubuntu:Pro:24.04:LTS
- Versiones
- 2.3.3-2.1
- 2.3.4-1
- 2.3.4-1build1
- 2.3.4-1build2
- 2.3.4-1build3
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.3.4-1ubuntu0.1~esm1
Actualiza a 2.3.4-1ubuntu0.1~esm1
fluidsynth Ubuntu:Pro:26.04:LTS
- Versiones
- 2.4.7+dfsg-2
- 2.4.8+dfsg-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.4.8+dfsg-1ubuntu0.1~esm1
Actualiza a 2.4.8+dfsg-1ubuntu0.1~esm1