p PatchFirst

CVE-2026-61736

CVE-2026-61736 · LightRAG: CORS Wildcard + Credentials Enables Any-Origin Credentialed Requests

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

LightRAG provides simple and fast retrieval-augmented generation. Prior to 1.5.4, the server defaults to CORS_ORIGINS=* combined with allow_credentials=True in lightrag/api/lightrag_server.py, causing Starlette CORSMiddleware to effectively whitelist every origin for credentialed cross-origin requests. Any malicious website visited by an authenticated LightRAG user can silently make authenticated API requests, exfiltrating documents and knowledge graph data or performing destructive actions such as deleting the document store. This vulnerability is fixed in 1.5.4.

CVSS 9.3 · Crítica · EPSS 1,4% · Código de explotación público · Corrección disponible

Publicación
Actualización

Pila tecnológica: python

Productos y versiones afectados

  • lightrag

    Versiones
    • < 1.5.4: Afectada

    Sin corrección publicada

  • lightrag-hku PyPI

    Versiones
    • 0.0.2
    • 0.0.3
    • 0.0.4
    • 0.0.5
    • 0.0.6
    • 0.0.7
    • 0.0.8
    • 0.0.9
    • 1.0.0
    • 1.0.1
    • 1.0.3
    • 1.0.5
    • 1.0.6
    • 1.0.8
    • 1.0.9
    • 1.1.0
    • 1.1.1
    • 1.1.2
    • 1.1.3
    • 1.1.4
    • 1.1.5
    • 1.1.6
    • 1.1.7
    • 1.2.1
    • 1.2.2
    • 1.2.3
    • 1.2.5
    • 1.2.6
    • 1.3.0
    • 1.3.1
    • 1.3.2
    • 1.3.3
    • 1.3.4
    • 1.3.5
    • 1.3.6
    • 1.3.7
    • 1.3.8
    • 1.3.9
    • 1.4.0
    • 1.4.1
    • 1.4.10
    • 1.4.11
    • 1.4.11rc2
    • 1.4.12
    • 1.4.12rc1
    • 1.4.13
    • 1.4.13rc1
    • 1.4.14
    • 1.4.15
    • 1.4.16
    • 1.4.2
    • 1.4.3
    • 1.4.4
    • 1.4.5
    • 1.4.6
    • 1.4.7
    • 1.4.8.1
    • 1.4.8.2
    • 1.4.8rc4
    • 1.4.8rc6
    • 1.4.8rc7
    • 1.4.8rc8
    • 1.4.8rc9
    • 1.4.9
    • 1.4.9.1
    • 1.4.9.10
    • 1.4.9.11
    • 1.4.9.2
    • 1.4.9.3
    • 1.4.9.4
    • 1.4.9.4rc1
    • 1.4.9.5
    • 1.4.9.6
    • 1.4.9.7
    • 1.4.9.8
    • 1.4.9.9
    • 1.4.9rc1
    • 1.4.9rc2
    • 1.4.9rc3
    • 1.4.9rc4
    • 1.5.0
    • 1.5.0rc1
    • 1.5.0rc2
    • 1.5.0rc3
    • 1.5.1
    • 1.5.2
    • 1.5.3
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.5.4

    Actualiza a 1.5.4

Fuentes originales

Comprueba tu servidor →