CVE-2026-62993
CVE-2026-62993 · Smarty: SSRF via redirect bypass of trusted_uri using {fetch}
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Smarty is a template engine for PHP, facilitating the separation of presentation (HTML/CSS) from application logic. Prior to 4.5.7 and 5.8.2, depending on the release line, Smarty's {fetch} handling in libs/plugins/function.fetch.php and src/FunctionHandler/Fetch.php used Security::isTrustedUri() to validate only the initial remote URL against trusted_uri when a security policy was active. For resources handled by file_get_contents(), including HTTPS URLs, PHP followed HTTP redirects by default. An attacker who could supply or influence a fetch target and had an open redirect on a trusted host could redirect the request to an attacker-chosen internal endpoint, bypass the trusted_uri allowlist, and perform server-side request forgery. This issue is fixed in versions 4.5.7 and 5.8.2.
CVSS 6.9 · Media · EPSS 0,6% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · php
Productos y versiones afectados
smarty
- Versiones
- >= 5.0.0, < 5.8.2: Afectada
- < 4.5.7: Afectada
Sin corrección publicada
smarty3 Debian:12
- Versiones
- 3.1.47-2
- 3.1.47-2+deb12u1
- 3.1.48-1
- 3.1.48-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
smarty3 Debian:13
- Versiones
- 3.1.48-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
smarty3 Debian:14
- Versiones
- 3.1.48-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
smarty4 Debian:12
- Versiones
- 4.3.0-1
- 4.3.0-1+deb12u1
- 4.3.0-1+deb12u2
- 4.3.1-1
- 4.5.4-1
- 4.5.5-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
smarty4 Debian:13
- Versiones
- 4.5.5-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
smarty4 Debian:14
- Versiones
- 4.5.5-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
smarty/smarty Packagist
- Versiones
- v5.0.0
- v5.0.1
- v5.0.2
- v5.1.0
- v5.2.0
- v5.3.0
- v5.3.1
- v5.4.0
- v5.4.1
- v5.4.2
- v5.4.3
- v5.4.4
- v5.4.5
- v5.5.0
- v5.5.1
- v5.5.2
- v5.6.0
- v5.7.0
- v5.8.0
- v5.8.1
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 5.0.0, < 5.8.2
Actualiza a 5.8.2
smarty/smarty Packagist
- Versiones
- v2.6.24
- v2.6.25
- v2.6.26
- v2.6.27
- v2.6.28
- v2.6.29
- v2.6.30
- v2.6.31
- v2.6.33
- v3.1.11
- v3.1.12
- v3.1.13
- v3.1.14
- v3.1.15
- v3.1.16
- v3.1.17
- v3.1.18
- v3.1.19
- v3.1.20
- v3.1.21
- v3.1.23
- v3.1.24
- v3.1.25
- v3.1.26
- v3.1.27
- v3.1.28
- v3.1.29
- v3.1.30
- v3.1.31
- v3.1.32
- v3.1.33
- v3.1.34
- v3.1.35
- v3.1.36
- v3.1.37
- v3.1.37.1
- v3.1.38
- v3.1.39
- v3.1.40
- v3.1.41
- v3.1.42
- v3.1.43
- v3.1.44
- v3.1.45
- v3.1.46
- v3.1.47
- v3.1.48
- v4.0.0
- v4.0.0-rc.0
- v4.0.1
- v4.0.2
- v4.0.3
- v4.0.4
- v4.1.0
- v4.1.1
- v4.2.0
- v4.2.1
- v4.3.0
- v4.3.1
- v4.3.2
- v4.3.3
- v4.3.4
- v4.3.5
- v4.4.0
- v4.4.1
- v4.5.0
- v4.5.1
- v4.5.2
- v4.5.3
- v4.5.4
- v4.5.5
- v4.5.6
- Intervalos de versiones afectados
- ECOSYSTEM: < 4.5.7
Actualiza a 4.5.7
smarty3 Ubuntu:Pro:16.04:LTS
- Versiones
- 3.1.21-1
- 3.1.21-1ubuntu1
- 3.1.21-1ubuntu1+esm1
- 3.1.21-1ubuntu1+esm2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
smarty3 Ubuntu:Pro:18.04:LTS
- Versiones
- 3.1.31+20161214.1.c7d42e4+selfpack1-2
- 3.1.31+20161214.1.c7d42e4+selfpack1-3
- 3.1.31+20161214.1.c7d42e4+selfpack1-3ubuntu0.1
- 3.1.31+20161214.1.c7d42e4+selfpack1-3ubuntu0.1+esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
smarty3 Ubuntu:Pro:20.04:LTS
- Versiones
- 3.1.33+20180830.1.3a78a21f+selfpack1-1
- 3.1.34+20190228.1.c9f0de05+selfpack1-1
- 3.1.34+20190228.1.c9f0de05+selfpack1-1ubuntu0.1~esm1
- 3.1.34+20190228.1.c9f0de05+selfpack1-1ubuntu0.1
- 3.1.34+20190228.1.c9f0de05+selfpack1-1ubuntu0.1+esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
smarty3 Ubuntu:22.04:LTS
- Versiones
- 3.1.39-2
- 3.1.39-2ubuntu1
- 3.1.39-2ubuntu1.22.04.1
- 3.1.39-2ubuntu1.22.04.2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
smarty3 Ubuntu:24.04:LTS
- Versiones
- 3.1.48-1
- 3.1.48-1ubuntu0.24.04.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
smarty4 Ubuntu:24.04:LTS
- Versiones
- 4.3.1-1
- 4.3.1-1ubuntu0.24.04.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
smarty3 Ubuntu:26.10
- Versiones
- 3.1.48-2build1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
smarty4 Ubuntu:26.10
- Versiones
- 4.5.5-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
smarty3 Ubuntu:26.04:LTS
- Versiones
- 3.1.48-2
- 3.1.48-2build1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
smarty4 Ubuntu:26.04:LTS
- Versiones
- 4.5.5-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/smarty-php/smarty/security/advisories/GHSA-cq55-c7wv-pxmq
- https://github.com/smarty-php/smarty/pull/1194
- https://github.com/smarty-php/smarty/commit/31e06fc087a8b5a9b236c1e5dacc1c2850a2c115
- https://github.com/smarty-php/smarty/commit/a1ccdb0518021a559b4066c37b76a42c86bbce90
- https://github.com/smarty-php/smarty/releases/tag/v4.5.7
- https://github.com/smarty-php/smarty/releases/tag/v5.8.2
- https://nvd.nist.gov/vuln/detail/CVE-2026-62993