CVE-2026-63220
CVE-2026-63220 · CodeIgniter: Spoofable forwarded HTTPS headers in IncomingRequest::isSecure()
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
CodeIgniter is a PHP full-stack web framework. In versions prior to 4.7.4, IncomingRequest::isSecure() trusted the X-Forwarded-Proto and Front-End-Https headers from any incoming request, allowing an attacker could spoof these headers and cause the application to incorrectly treat an HTTP request as secure. This may have impacted applications that rely on isSecure(), force_https(), forceGlobalSecureRequests, or similar logic to enforce HTTPS-only access or make security-sensitive decisions. Exploitability depends on deployment configuration. Applications are most exposed if the backend is reachable directly over HTTP, or if a reverse proxy/load balancer forwards client-supplied forwarding headers without stripping or overwriting them. This issue has been fixed in version 4.7.4.
CVSS 4.8 · Media · EPSS 0,2% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · php
Productos y versiones afectados
codeigniter4
- Versiones
- < 4.7.4: Afectada
Sin corrección publicada
codeigniter4/framework Packagist
- Versiones
- 4.0.0
- 4.0.0-rc.4
- v4.0.0-alpha.3
- v4.0.0-alpha.4
- v4.0.0-alpha.5
- v4.0.0-beta.1
- v4.0.0-beta.2
- v4.0.0-beta.3
- v4.0.0-beta.4
- v4.0.0-rc.1
- v4.0.0-rc.2
- v4.0.0-rc.2.1
- v4.0.0-rc.3
- v4.0.1
- v4.0.2
- v4.0.3
- v4.0.4
- v4.0.5
- v4.1.0
- v4.1.1
- v4.1.2
- v4.1.3
- v4.1.4
- v4.1.5
- v4.1.6
- v4.1.7
- v4.1.8
- v4.1.9
- v4.2.0
- v4.2.1
- v4.2.10
- v4.2.11
- v4.2.12
- v4.2.2
- v4.2.3
- v4.2.4
- v4.2.5
- v4.2.6
- v4.2.7
- v4.2.8
- v4.2.9
- v4.3.0
- v4.3.1
- v4.3.2
- v4.3.3
- v4.3.4
- v4.3.5
- v4.3.6
- v4.3.7
- v4.3.8
- v4.4.0
- v4.4.1
- v4.4.2
- v4.4.3
- v4.4.4
- v4.4.5
- v4.4.6
- v4.4.7
- v4.4.8
- v4.5.0
- v4.5.1
- v4.5.2
- v4.5.3
- v4.5.4
- v4.5.5
- v4.5.6
- v4.5.7
- v4.5.8
- v4.6.0
- v4.6.1
- v4.6.2
- v4.6.3
- v4.6.4
- v4.6.5
- v4.7.0
- v4.7.1
- v4.7.2
- v4.7.3
- Intervalos de versiones afectados
- ECOSYSTEM: < 4.7.4
Actualiza a 4.7.4
php-codeigniter-framework Ubuntu:24.04:LTS
- Versiones
- 3.1.13+dfsg1-1
- 3.1.13+dfsg1-2
- 3.1.13+dfsg1-2ubuntu2
- 3.1.13+dfsg1-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
php-codeigniter-framework Ubuntu:26.10
- Versiones
- 3.1.13+dfsg1-8
- 3.1.13+dfsg1-9
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
php-codeigniter-framework Ubuntu:26.04:LTS
- Versiones
- 3.1.13+dfsg1-6
- 3.1.13+dfsg1-8
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada