CVE-2026-63349
CVE-2026-63349 · AnyIO run_process/open_process ignores extra_groups and can retain parent supplementary groups
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
AnyIO is a high level asynchronous concurrency and networking framework that works on top of either Trio or asyncio. In 4.14.0, AnyIO accepts the POSIX extra_groups argument in anyio.run_process() and anyio.open_process(), but open_process() forwards the group argument to the backend instead of extra_groups. A caller that supplies extra_groups=[] to clear inherited supplementary groups can therefore launch a child that retains the parent process groups, undermining a privilege-dropping boundary. If group is also supplied, the integer group value is passed where an iterable of supplementary groups is expected and the launch can fail with TypeError. This issue affects POSIX applications that rely on AnyIO subprocess helpers to launch less-privileged child processes. This issue is fixed in version 4.14.2.
CVSS 7.0 · Alta · EPSS 0,1% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · python
Productos y versiones afectados
anyio
- Versiones
- >= 4.14.0, < 4.14.2: Afectada
Sin corrección publicada
python-anyio Debian:12
- Versiones
- 3.6.2-1
- 3.7.0-1
- 4.1.0-1
- 4.11.0-1
- 4.11.0-2
- 4.11.0-3
- 4.12.1-1
- 4.12.1-2
- 4.12.1-3
- 4.15.1-1
- 4.15.1-2
- 4.15.1-3
- 4.2.0-1
- 4.3.0-1
- 4.4.0-1
- 4.6.0-1
- 4.6.2-1
- 4.6.2-2
- 4.6.2-3
- 4.6.2-4
- 4.7.0-1
- 4.8.0-1
- 4.8.0-2
- 4.8.0-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
python-anyio Debian:13
- Versiones
- 4.11.0-1
- 4.11.0-2
- 4.11.0-3
- 4.12.1-1
- 4.12.1-2
- 4.12.1-3
- 4.15.1-1
- 4.15.1-2
- 4.15.1-3
- 4.8.0-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
python-anyio Debian:14
- Versiones
- 4.11.0-1
- 4.11.0-2
- 4.11.0-3
- 4.12.1-1
- 4.12.1-2
- 4.12.1-3
- 4.8.0-3
- Intervalos de versiones afectados
- ECOSYSTEM: < 4.15.1-1
Actualiza a 4.15.1-1
anyio PyPI
- Versiones
- 4.14.0
- 4.14.1
- Intervalos de versiones afectados
- ECOSYSTEM: ≥ 4.14.0, < 4.14.2
Actualiza a 4.14.2
python-anyio Ubuntu:22.04:LTS
- Versiones
- 2.0.2-2
- 3.5.0-2ubuntu1
- 3.5.0-3ubuntu2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
python-anyio Ubuntu:24.04:LTS
- Versiones
- 3.7.0-1
- 4.2.0-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
python-anyio Ubuntu:26.10
- Versiones
- 4.11.0-3
- 4.12.1-2
- 4.12.1-3
- 4.15.1-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
python-anyio Ubuntu:26.04:LTS
- Versiones
- 4.8.0-3
- 4.11.0-2
- 4.11.0-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/agronholm/anyio/security/advisories/GHSA-3w57-8xmc-8v26
- https://github.com/agronholm/anyio/pull/1209
- https://github.com/agronholm/anyio/commit/eb562e6462ee46b1904e50b02ce00a858cdeb200
- https://github.com/agronholm/anyio/releases/tag/4.14.2
- https://nvd.nist.gov/vuln/detail/CVE-2026-63349