CVE-2026-63381
CVE-2026-63381 · Libevent: Dangling Pointer in `evbuffer_add_buffer_reference`
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Libevent is an event notification library. Prior to 2.1.13 and 2.2.2-alpha, libevent has a use-after-free in buffer.c when evbuffer_add_buffer_reference processes an output buffer whose out_total_len is zero. evbuffer_free_all_chains frees the initial empty chain without resetting outbuf->first, outbuf->last, or outbuf->last_with_datap, and APPEND_CHAIN_MULTICAST subsequently dereferences the dangling chain pointer. A caller that can drive this buffer state can cause memory corruption or a process crash. This issue is fixed in versions 2.1.13 and 2.2.2-alpha.
CVSS 5.8 · Media · EPSS 0,2% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
libevent
- Versiones
- >= 2.2.0-alpha, < 2.2.2-alpha: Afectada
- < 2.1.13: Afectada
Sin corrección publicada
libevent Debian:12
- Versiones
- 2.1.12-stable-8
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.1.12-stable-8+deb12u1
Actualiza a 2.1.12-stable-8+deb12u1
libevent Debian:13
- Versiones
- 2.1.12-stable-10
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.1.13-stable-1~deb13u1
Actualiza a 2.1.13-stable-1~deb13u1
libevent Debian:14
- Versiones
- 2.1.12-stable-10
- 2.1.13-stable-1~deb13u1
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.1.13-stable-1
Actualiza a 2.1.13-stable-1
libevent Ubuntu:Pro:18.04:LTS
- Versiones
- 2.1.8-stable-4
- 2.1.8-stable-4build1
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.1.8-stable-4ubuntu0.1~esm1
Actualiza a 2.1.8-stable-4ubuntu0.1~esm1
libevent Ubuntu:Pro:20.04:LTS
- Versiones
- 2.1.8-stable-4build1
- 2.1.11-stable-1~exp0
- 2.1.11-stable-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.1.11-stable-1ubuntu0.1~esm1
Actualiza a 2.1.11-stable-1ubuntu0.1~esm1
libevent Ubuntu:22.04:LTS
- Versiones
- 2.1.12-stable-1
- 2.1.12-stable-1build1
- 2.1.12-stable-1build2
- 2.1.12-stable-1build3
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.1.12-stable-1ubuntu0.1
Actualiza a 2.1.12-stable-1ubuntu0.1
libevent Ubuntu:24.04:LTS
- Versiones
- 2.1.12-stable-9
- 2.1.12-stable-9ubuntu2
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.1.12-stable-9ubuntu2.1
Actualiza a 2.1.12-stable-9ubuntu2.1
libevent Ubuntu:26.04:LTS
- Versiones
- 2.1.12-stable-10build1
- 2.1.12-stable-10build2
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.1.12-stable-10ubuntu0.1
Actualiza a 2.1.12-stable-10ubuntu0.1
Fuentes originales
- https://github.com/libevent/libevent/security/advisories/GHSA-c2pj-cg4r-88c8
- https://github.com/libevent/libevent/commit/5cb95ba2f804f8aff46f88d58391c71e1251cd1c
- https://github.com/libevent/libevent/commit/9db091b04f569be3a700fa9860ef02f90b830af9
- https://github.com/libevent/libevent/releases/tag/release-2.1.13-stable
- https://github.com/libevent/libevent/releases/tag/release-2.2.2-alpha
- https://nvd.nist.gov/vuln/detail/CVE-2026-63381