CVE-2026-63384
CVE-2026-63384 · Libevent: `evtag_unmarshal_header()` decodes a wire `uint32` length into a signed `int` return value.
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Libevent is an event notification library. Prior to 2.1.13 and 2.2.2-alpha, libevent has an incorrect integer conversion in event_tagging.c when evtag_unmarshal_header uses evtag_decode_int to decode an attacker-controlled uint32 payload length and returns it as a signed int. Values above INT_MAX become negative or truncated, and evtag_unmarshal_string can use the converted value in allocation sizing, producing a wrapped large allocation request and denial of service. This issue is fixed in versions 2.1.13 and 2.2.2-alpha.
CVSS 8.7 · Alta · EPSS 0,5% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
libevent
- Versiones
- >= 2.2.0-alpha, < 2.2.2-alpha: Afectada
- < 2.1.13: Afectada
Sin corrección publicada
libevent Debian:12
- Versiones
- 2.1.12-stable-8
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.1.12-stable-8+deb12u1
Actualiza a 2.1.12-stable-8+deb12u1
libevent Debian:13
- Versiones
- 2.1.12-stable-10
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.1.13-stable-1~deb13u1
Actualiza a 2.1.13-stable-1~deb13u1
libevent Debian:14
- Versiones
- 2.1.12-stable-10
- 2.1.13-stable-1~deb13u1
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.1.13-stable-1
Actualiza a 2.1.13-stable-1
libevent Ubuntu:Pro:14.04:LTS
- Versiones
- 2.0.21-stable-1
- 2.0.21-stable-1ubuntu1
- 2.0.21-stable-1ubuntu1.14.04.1
- 2.0.21-stable-1ubuntu1.14.04.2
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.0.21-stable-1ubuntu1.14.04.2+esm1
Actualiza a 2.0.21-stable-1ubuntu1.14.04.2+esm1
libevent Ubuntu:Pro:16.04:LTS
- Versiones
- 2.0.21-stable-2
- 2.0.21-stable-2ubuntu0.16.04.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.0.21-stable-2ubuntu0.16.04.1+esm1
Actualiza a 2.0.21-stable-2ubuntu0.16.04.1+esm1
libevent Ubuntu:Pro:18.04:LTS
- Versiones
- 2.1.8-stable-4
- 2.1.8-stable-4build1
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.1.8-stable-4ubuntu0.1~esm1
Actualiza a 2.1.8-stable-4ubuntu0.1~esm1
libevent Ubuntu:Pro:20.04:LTS
- Versiones
- 2.1.8-stable-4build1
- 2.1.11-stable-1~exp0
- 2.1.11-stable-1
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.1.11-stable-1ubuntu0.1~esm1
Actualiza a 2.1.11-stable-1ubuntu0.1~esm1
libevent Ubuntu:22.04:LTS
- Versiones
- 2.1.12-stable-1
- 2.1.12-stable-1build1
- 2.1.12-stable-1build2
- 2.1.12-stable-1build3
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.1.12-stable-1ubuntu0.1
Actualiza a 2.1.12-stable-1ubuntu0.1
libevent Ubuntu:24.04:LTS
- Versiones
- 2.1.12-stable-9
- 2.1.12-stable-9ubuntu2
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.1.12-stable-9ubuntu2.1
Actualiza a 2.1.12-stable-9ubuntu2.1
libevent Ubuntu:26.04:LTS
- Versiones
- 2.1.12-stable-10build1
- 2.1.12-stable-10build2
- Intervalos de versiones afectados
- ECOSYSTEM: < 2.1.12-stable-10ubuntu0.1
Actualiza a 2.1.12-stable-10ubuntu0.1
Fuentes originales
- https://github.com/libevent/libevent/security/advisories/GHSA-45c6-qx49-89m8
- https://github.com/libevent/libevent/commit/109c16499282959d70f56ec3baf4c8b1e6646bda
- https://github.com/libevent/libevent/commit/5e3c6ebe342b34c5a9bcf48e9a32ad6708b9c416
- https://github.com/libevent/libevent/releases/tag/release-2.1.13-stable
- https://github.com/libevent/libevent/releases/tag/release-2.2.2-alpha
- https://nvd.nist.gov/vuln/detail/CVE-2026-63384