CVE-2026-66858
CVE-2026-66858 · Apache Thrift, Apache Thrift, Apache Thrift, Apache Thrift, Apache Thrift, Apache Thrift: skip() does not apply the recursion limit (Python accelerator, PHP, Perl, Lua, Smalltalk, OCaml)
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
The protocol skip routine in several Apache Thrift bindings did not apply the binding's recursion limit, so a message that nests unknown fields deeply enough can exhaust the stack. Affected: the Python C++ accelerator (the pure-Python protocols are not affected), the PHP library and its thrift_protocol extension, and the Perl, Lua, Smalltalk and OCaml libraries. This issue affects Apache Thrift: before 0.25.0. Users are recommended to upgrade to version 0.25.0, which fixes the issue.
CVSS 8.7 · Alta · EPSS 0,3% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system
Productos y versiones afectados
apache thrift
- Versiones
- ≥ 0, < 0.25.0: Afectada (semver)
Actualiza a 0.25.0
thrift Debian:12
- Versiones
- 0.17.0-2
- 0.17.0-3
- 0.17.0-4
- 0.18.1-1
- 0.18.1-2
- 0.19.0-1
- 0.19.0-2
- 0.19.0-2.1
- 0.19.0-2.1~exp1
- 0.19.0-3
- 0.19.0-4
- 0.20.0-1
- 0.22.0-1
- 0.22.0-2
- 0.22.0-3
- 0.22.0-4
- 0.23.0-1
- 0.23.0-2
- 0.23.0-3
- 0.24.0-1
- 0.24.0-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
thrift Debian:13
- Versiones
- 0.19.0-4
- 0.20.0-1
- 0.22.0-1
- 0.22.0-2
- 0.22.0-3
- 0.22.0-4
- 0.23.0-1
- 0.23.0-2
- 0.23.0-3
- 0.24.0-1
- 0.24.0-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
thrift Debian:14
- Versiones
- 0.19.0-4
- 0.20.0-1
- 0.22.0-1
- 0.22.0-2
- 0.22.0-3
- 0.22.0-4
- 0.23.0-1
- 0.23.0-2
- 0.23.0-3
- 0.24.0-1
- 0.24.0-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
php-horde-thrift Ubuntu:16.04:LTS
- Versiones
- 2.0.2-2
- 2.0.2-3
- 2.0.2-3build1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
python-thrift Ubuntu:16.04:LTS
- Versiones
- 0.9.1-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
php-horde-thrift Ubuntu:18.04:LTS
- Versiones
- 2.0.2-5
- 2.0.3-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
python-thrift Ubuntu:18.04:LTS
- Versiones
- 0.9.1-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
thrift Ubuntu:20.04:LTS
- Versiones
- 0.11.0-6
- 0.13.0-2build1
- 0.13.0-2build2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
thrift Ubuntu:22.04:LTS
- Versiones
- 0.13.0-6ubuntu1
- 0.13.0-6ubuntu2
- 0.13.0-6ubuntu3
- 0.13.0-7
- 0.16.0-2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
thrift Ubuntu:24.04:LTS
- Versiones
- 0.17.0-4
- 0.19.0-2
- 0.19.0-2build1
- 0.19.0-2.1build4
- 0.19.0-2.1build5
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
thrift Ubuntu:26.10
- Versiones
- 0.22.0-3ubuntu1
- 0.23.0-3
- 0.23.0-3ubuntu1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
thrift Ubuntu:26.04:LTS
- Versiones
- 0.19.0-4build1
- 0.22.0-3
- 0.22.0-3ubuntu1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada