CVE-2026-67238
CVE-2026-67238 · RabbitMQ: Atom-table exhaustion via reply-to queue name decoding
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
RabbitMQ is a messaging and streaming broker. Prior to versions 4.2.7 and 4.3.1, rabbit_pid_codec:decompose_from_binary/1 parses a caller-supplied ETF-encoded binary and calls binary_to_atom(Node, utf8) on the node-name field. It is reached from rabbit_volatile_queue:pid_from_name/2, which is invoked for any queue name / routing key beginning amq.rabbitmq.reply-to.. The CandidateNodes membership check happens after the atom is created, and the surrounding try/catch cannot reclaim atoms (they are never GC'd). binary_to_existing_atom is not used. Any authenticated AMQP client can crash the entire Erlang VM (all vhosts, all connections) with ~1M cheap requests. Preconditions include Authenticated AMQP 0-9-1 connection to any vhost No per-connection rate limit low enough to make ~1M operations infeasible. This issue is fixed in versions 4.2.7 and 4.3.1.
CVSS 7.1 · Alta · EPSS 0,3% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · database
Productos y versiones afectados
rabbitmq
- Versiones
- >= 4.2.0, < 4.2.7: Afectada
- >= 4.3.0, < 4.3.1: Afectada
Sin corrección publicada
rabbitmq-server Debian:14
- Versiones
- 4.0.5-10
- 4.0.5-11
- 4.0.5-12
- 4.0.5-13
- 4.0.5-14
- 4.0.5-6
- 4.0.5-8
- 4.0.5-9
- 4.3.0-1
- 4.3.0-2
- 4.3.0-3
- Intervalos de versiones afectados
- ECOSYSTEM: < 4.3.2-1
Actualiza a 4.3.2-1
rabbitmq-server Ubuntu:Pro:16.04:LTS
- Versiones
- 3.5.4-1
- 3.5.4-3
- 3.5.4-3.1
- 3.5.7-1
- 3.5.7-1ubuntu0.16.04.1
- 3.5.7-1ubuntu0.16.04.2
- 3.5.7-1ubuntu0.16.04.4
- 3.5.7-1ubuntu0.16.04.4+esm1
- 3.5.7-1ubuntu0.16.04.4+esm2
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.5.7-1ubuntu0.16.04.4+esm3
Actualiza a 3.5.7-1ubuntu0.16.04.4+esm3
rabbitmq-server Ubuntu:Pro:18.04:LTS
- Versiones
- 3.6.10-1
- 3.6.10-1ubuntu0.1
- 3.6.10-1ubuntu0.3
- 3.6.10-1ubuntu0.4
- 3.6.10-1ubuntu0.5
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.6.10-1ubuntu0.5+esm1
Actualiza a 3.6.10-1ubuntu0.5+esm1
rabbitmq-server Ubuntu:Pro:20.04:LTS
- Versiones
- 3.7.8-4ubuntu2
- 3.7.18-1
- 3.8.2-0ubuntu1
- 3.8.2-0ubuntu1.1
- 3.8.2-0ubuntu1.2
- 3.8.2-0ubuntu1.3
- 3.8.2-0ubuntu1.4
- 3.8.2-0ubuntu1.5
- 3.8.3-0ubuntu0.1
- 3.8.3-0ubuntu0.2
- 3.8.3-0ubuntu0.3
- 3.8.3-0ubuntu0.3+esm1
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.8.3-0ubuntu0.3+esm2
Actualiza a 3.8.3-0ubuntu0.3+esm2
rabbitmq-server Ubuntu:22.04:LTS
- Versiones
- 3.8.9-3ubuntu1
- 3.9.8-1
- 3.9.8-2
- 3.9.8-3
- 3.9.8-5
- 3.9.8-6
- 3.9.13-1
- 3.9.13-1ubuntu0.22.04.1
- 3.9.13-1ubuntu0.22.04.2
- 3.9.27-0ubuntu0.1
- 3.9.27-0ubuntu0.2
- 3.9.27-0ubuntu0.5
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.9.27-0ubuntu0.6
Actualiza a 3.9.27-0ubuntu0.6
rabbitmq-server Ubuntu:24.04:LTS
- Versiones
- 3.12.1-1
- 3.12.1-1ubuntu1
- 3.12.1-1ubuntu1.2
- 3.12.1-1ubuntu1.4
- 3.12.1-1ubuntu1.6
- Intervalos de versiones afectados
- ECOSYSTEM: < 3.12.1-1ubuntu1.7
Actualiza a 3.12.1-1ubuntu1.7
rabbitmq-server Ubuntu:26.04:LTS
- Versiones
- 4.0.5-8ubuntu2
- 4.0.5-10ubuntu1
- 4.0.5-10ubuntu2
- 4.0.5-10ubuntu3
- 4.0.5-10ubuntu4
- 4.0.5-10ubuntu5
- 4.0.5-10ubuntu5.1
- Intervalos de versiones afectados
- ECOSYSTEM: < 4.0.5-10ubuntu5.2
Actualiza a 4.0.5-10ubuntu5.2