p PatchFirst

CVE-2026-67320

CVE-2026-67320 · axios before 0.33.0 Prototype Pollution via Node HTTP adapter

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

axios in a Node.js deployment using the HTTP adapter can route requests through an attacker-controlled proxy. axios hardens merged request configuration by creating a null-prototype object, but request interceptors run after the merge; a common immutable interceptor pattern such as {...config} or Object.assign({}, config) converts the hardened config back into a regular object. axios then dispatches that object without re-hardening it, and the Node HTTP adapter reads config.proxy through the prototype chain. If an attacker can pollute Object.prototype.proxy, affected requests can be routed through an attacker-controlled proxy. For plaintext HTTP requests, the proxy can observe Authorization headers, Basic auth from config.auth, method, absolute URL, Host, and request body, and can return its own response. This does not establish browser impact or HTTPS header/body disclosure under normal TLS validation. Affected versions are >=0.31.1 (fixed in 0.33.0) and >=1.15.2 (fixed in 1.18.0).

CVSS 8.3 · Alta · EPSS 0,5% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · node

Productos y versiones afectados

  • axios

    Versiones
    • ≥ 0.31.1, < 0.33.0: Afectada (semver)
    • 0.33.0: No afectada (semver)

    Actualiza a 0.33.0

  • axios

    Versiones
    • ≥ 1.15.2, < 1.18.0: Afectada (semver)
    • 1.18.0: No afectada (semver)

    Actualiza a 1.18.0

  • node-axios Debian:14

    Versiones
    • 1.11.0+dfsg-1
    • 1.12.1+dfsg-1
    • 1.13.1+dfsg-1
    • 1.13.2+dfsg-1
    • 1.14.0+dfsg-1
    • 1.15.0-1
    • 1.15.2-1
    • 1.16.0-1
    • 1.8.4+dfsg-1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 1.18.0-1

    Actualiza a 1.18.0-1

  • axios npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 0.31.1, < 0.33.0

    Actualiza a 0.33.0

  • axios npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 1.15.2, < 1.18.0

    Actualiza a 1.18.0

  • node-axios Ubuntu:Pro:20.04:LTS

    Versiones
    • 0.19.0+dfsg-2
    • 0.19.0+dfsg-2ubuntu0.1~esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-axios Ubuntu:Pro:22.04:LTS

    Versiones
    • 0.21.1+dfsg-1
    • 0.23.0+dfsg-2
    • 0.24.0+dfsg-1
    • 0.25.0+dfsg-2
    • 0.26.0+dfsg-1
    • 0.26.0+dfsg-1ubuntu0.1~esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-axios Ubuntu:Pro:24.04:LTS

    Versiones
    • 1.2.1+dfsg-1
    • 1.5.1+dfsg-1
    • 1.6.2+dfsg-1
    • 1.6.8+dfsg-2
    • 1.6.8+dfsg-2ubuntu0.1~esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-axios Ubuntu:Pro:26.04:LTS

    Versiones
    • 1.11.0+dfsg-1
    • 1.12.1+dfsg-1
    • 1.13.2+dfsg-1build1
    • 1.13.2+dfsg-1ubuntu0.1~esm1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →