CVE-2026-67413
CVE-2026-67413 · RabbitMQ: Authenticated RabbitMQ JMS Topic Selector Users Can Consume Broker CPU with an Unbounded LIKE Regular Expression
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
RabbitMQ is a messaging and streaming broker. From 4.0.0 until 4.0.23, 4.1.14, 4.2.9, and 4.3.3, the optional rabbitmq_jms_topic_exchange plugin's x-jms-topic exchange accepted a client-controlled rjms_erlang_selector binding expression whose LIKE evaluator expanded percent and underscore wildcards into overlapping PCRE fragments. It executed those fragments with raw re:run/3 without match or recursion limits, allowing an authenticated tenant that can bind and publish to consume broker scheduler CPU and deny service with pathological selectors. This issue is fixed in versions 4.0.23, 4.1.14, 4.2.9, and 4.3.3.
CVSS 6.0 · Media · EPSS 0,5% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · database
Productos y versiones afectados
rabbitmq
- Versiones
- >= 4.2.0, < 4.2.9: Afectada
- >= 4.1.0, < 4.1.14: Afectada
- >= 4.3.0, < 4.3.3: Afectada
- >= 4.0.0, < 4.0.23: Afectada
Sin corrección publicada
rabbitmq-server Debian:12
- Versiones
- 3.10.8-1.1
- 3.10.8-1.1+deb12u1
- 3.10.8-2
- 3.10.8-3
- 3.10.8-4
- 3.12.1-1
- 3.12.1-1.1
- 4.0.5-1
- 4.0.5-10
- 4.0.5-11
- 4.0.5-12
- 4.0.5-13
- 4.0.5-14
- 4.0.5-2
- 4.0.5-3
- 4.0.5-4
- 4.0.5-5
- 4.0.5-6
- 4.0.5-8
- 4.0.5-9
- 4.3.0-1
- 4.3.0-2
- 4.3.0-3
- 4.3.2-1
- 4.3.2-2
- 4.3.2-3
- 4.3.2-4
- 4.3.2-5
- 4.3.6-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
rabbitmq-server Debian:13
- Versiones
- 4.0.5-10
- 4.0.5-11
- 4.0.5-12
- 4.0.5-13
- 4.0.5-14
- 4.0.5-6
- 4.0.5-6+deb13u1
- 4.0.5-6+deb13u2
- 4.0.5-8
- 4.0.5-9
- 4.3.0-1
- 4.3.0-2
- 4.3.0-3
- 4.3.2-1
- 4.3.2-2
- 4.3.2-3
- 4.3.2-4
- 4.3.2-5
- 4.3.6-1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
rabbitmq-server Debian:14
- Versiones
- 4.0.5-10
- 4.0.5-11
- 4.0.5-12
- 4.0.5-13
- 4.0.5-14
- 4.0.5-6
- 4.0.5-8
- 4.0.5-9
- 4.3.0-1
- 4.3.0-2
- 4.3.0-3
- 4.3.2-1
- 4.3.2-2
- 4.3.2-3
- 4.3.2-4
- 4.3.2-5
- Intervalos de versiones afectados
- ECOSYSTEM: < 4.3.6-1
Actualiza a 4.3.6-1
rabbitmq-server Ubuntu:Pro:16.04:LTS
- Versiones
- 3.5.4-1
- 3.5.4-3
- 3.5.4-3.1
- 3.5.7-1
- 3.5.7-1ubuntu0.16.04.1
- 3.5.7-1ubuntu0.16.04.2
- 3.5.7-1ubuntu0.16.04.4
- 3.5.7-1ubuntu0.16.04.4+esm1
- 3.5.7-1ubuntu0.16.04.4+esm2
- 3.5.7-1ubuntu0.16.04.4+esm3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
rabbitmq-server Ubuntu:Pro:18.04:LTS
- Versiones
- 3.6.10-1
- 3.6.10-1ubuntu0.1
- 3.6.10-1ubuntu0.3
- 3.6.10-1ubuntu0.4
- 3.6.10-1ubuntu0.5
- 3.6.10-1ubuntu0.5+esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
rabbitmq-server Ubuntu:Pro:20.04:LTS
- Versiones
- 3.7.8-4ubuntu2
- 3.7.18-1
- 3.8.2-0ubuntu1
- 3.8.2-0ubuntu1.1
- 3.8.2-0ubuntu1.2
- 3.8.2-0ubuntu1.3
- 3.8.2-0ubuntu1.4
- 3.8.2-0ubuntu1.5
- 3.8.3-0ubuntu0.1
- 3.8.3-0ubuntu0.2
- 3.8.3-0ubuntu0.3
- 3.8.3-0ubuntu0.3+esm1
- 3.8.3-0ubuntu0.3+esm2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
rabbitmq-server Ubuntu:22.04:LTS
- Versiones
- 3.8.9-3ubuntu1
- 3.9.8-1
- 3.9.8-2
- 3.9.8-3
- 3.9.8-5
- 3.9.8-6
- 3.9.13-1
- 3.9.13-1ubuntu0.22.04.1
- 3.9.13-1ubuntu0.22.04.2
- 3.9.27-0ubuntu0.1
- 3.9.27-0ubuntu0.2
- 3.9.27-0ubuntu0.5
- 3.9.27-0ubuntu0.6
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
rabbitmq-server Ubuntu:24.04:LTS
- Versiones
- 3.12.1-1
- 3.12.1-1ubuntu1
- 3.12.1-1ubuntu1.2
- 3.12.1-1ubuntu1.4
- 3.12.1-1ubuntu1.6
- 3.12.1-1ubuntu1.7
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
rabbitmq-server Ubuntu:26.10
- Versiones
- 4.0.5-10ubuntu5
- 4.3.2-4ubuntu2
- 4.3.2-4ubuntu3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
rabbitmq-server Ubuntu:26.04:LTS
- Versiones
- 4.0.5-8ubuntu2
- 4.0.5-10ubuntu1
- 4.0.5-10ubuntu2
- 4.0.5-10ubuntu3
- 4.0.5-10ubuntu4
- 4.0.5-10ubuntu5
- 4.0.5-10ubuntu5.1
- 4.0.5-10ubuntu5.2
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/rabbitmq/rabbitmq-server/security/advisories/GHSA-chxf-3hfg-j8f7
- https://github.com/rabbitmq/rabbitmq-server/commit/20203c50ea6ff459d462b2d4355326d3a870682c
- https://github.com/rabbitmq/rabbitmq-server/commit/60de2fbbcd812ab294985cef260cc2f1b1a02a5b
- https://github.com/rabbitmq/rabbitmq-server/commit/9e36b7f4c1e2eed77300288dca3e01bd9b23c432
- https://github.com/rabbitmq/rabbitmq-server/commit/f4d9da668b7304dfb9aeb2b4e9ff766a1275d021
- https://github.com/rabbitmq/rabbitmq-server/releases/tag/v4.2.9
- https://github.com/rabbitmq/rabbitmq-server/releases/tag/v4.3.3
- https://nvd.nist.gov/vuln/detail/CVE-2026-67413