CVE-2026-68945
CVE-2026-68945 · Angular: Cache-Key Ambiguity in HttpTransferCache Leading to Cross-Request Response Reuse and State Poisoning
Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.
Angular is a development platform for building mobile and desktop web applications using TypeScript/JavaScript and other languages. Prior to 20.3.27, 21.2.19, and 22.0.2, HttpTransferCache comma-joins repeated request parameters, allowing semantically distinct HttpClient requests to use the same transfer-cache key and reuse a wrong backend response. This issue is fixed in versions 20.3.27, 21.2.19, and 22.0.2.
CVSS 8.8 · Alta · EPSS 0,2% · Corrección disponible
- Publicación
- Actualización
Pila tecnológica: system · node
Productos y versiones afectados
angular
- Versiones
- < 20.3.27: Afectada
- >= 21.0.0-next.0, < 21.2.19: Afectada
- >= 22.0.0-next.0, < 22.0.2: Afectada
Sin corrección publicada
common
- Versiones
- < 20.3.27: Afectada
- >= 21.0.0-next.0, < 21.2.19: Afectada
- >= 22.0.0-next.0, < 22.0.2: Afectada
Sin corrección publicada
angular.js Debian:12
- Versiones
- 1.8.3-1
- 1.8.3-1+deb12u1
- 1.8.3-1+deb12u1~deb11u1
- 1.8.3-2
- 1.8.3-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
angular.js Debian:13
- Versiones
- 1.8.3-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
@angular/common npm
- Intervalos de versiones afectados
- SEMVER: ≥ 22.0.0-next.0, < 22.0.2
Actualiza a 22.0.2
@angular/common npm
- Intervalos de versiones afectados
- SEMVER: ≥ 21.0.0-next.0, < 21.2.19
Actualiza a 21.2.19
@angular/common npm
- Intervalos de versiones afectados
- SEMVER: ≥ 20.0.0-next.0, < 20.3.27
Actualiza a 20.3.27
@angular/common npm
- Intervalos de versiones afectados
- SEMVER: ≤ 19.2.25
Sin corrección publicada
angular.js Ubuntu:Pro:16.04:LTS
- Versiones
- 1.2.28-1ubuntu2
- 1.2.28-1ubuntu2+esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
angular.js Ubuntu:Pro:18.04:LTS
- Versiones
- 1.5.10-1
- 1.5.10-1ubuntu0.1~esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
angular.js Ubuntu:Pro:20.04:LTS
- Versiones
- 1.5.10-1
- 1.7.9-1
- 1.7.9-1ubuntu0.1~esm1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
angular.js Ubuntu:22.04:LTS
- Versiones
- 1.8.2-2
- 1.8.2-2ubuntu0.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
angular.js Ubuntu:24.04:LTS
- Versiones
- 1.8.3-1
- 1.8.3-1ubuntu0.24.04.1
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
angular.js Ubuntu:26.10
- Versiones
- 1.8.3-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
angular.js Ubuntu:26.04:LTS
- Versiones
- 1.8.3-3
- Intervalos de versiones afectados
- ECOSYSTEM: (−∞, +∞)
Sin corrección publicada
Fuentes originales
- https://github.com/angular/angular/security/advisories/GHSA-jhpw-976m-542j
- https://github.com/angular/angular/pull/68571
- https://github.com/angular/angular/commit/6867f77ec779a0a24f6339ad6c775f444202103c
- https://github.com/angular/angular/commit/948a8d6831e8920b54663ec79421da95210e0e35
- https://github.com/angular/angular/commit/a64e2883e9dc4abdac70209129be303de79e5b2b
- https://github.com/angular/angular/commit/a6c7fc5c13e6e494a4c9bd8e773b8d4b2a99b20c
- https://nvd.nist.gov/vuln/detail/CVE-2026-68945