p PatchFirst

CVE-2026-71436

CVE-2026-71436 · Mermaid XY Charts are vulnerable to an infinite loop DoS

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Mermaid is a JavaScript tool that uses Markdown-inspired text to create and modify diagrams and charts. From version 10.6.0 until 10.9.8 and 11.16.1, Mermaid XY Charts are vulnerable to an infinite loop denial of service in the setXAxisRangeData function when configuring an X-Axis with invalid parameters. Because each loop iteration appends an element to an array, this generally causes a RangeError to appear after a few seconds, but it may instead cause the page or JavaScript process to crash from memory exhaustion, depending on the environment. This issue is fixed in versions 10.9.8 and 11.16.1.

CVSS 5.3 · Media · EPSS 0,6% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system · node

Productos y versiones afectados

  • mermaid

    Versiones
    • >= 10.6.0, < 10.9.8: Afectada
    • >= 11.0.0-alpha.1, < 11.16.1: Afectada

    Sin corrección publicada

  • node-mermaid Debian:14

    Versiones
    • 8.11.0+ds+~cs29.13.22-1
    • 8.13.2+ds+~cs30.13.21-1
    • 8.13.2+ds+~cs30.13.21-1.1
    • 8.13.3+ds+~cs26.13.21-1
    • 8.13.3+ds+~cs26.13.21-2
    • 8.13.8+~cs10.4.16-1
    • 8.14.0+ds1+~cs11.4.14-1
    • 8.14.0+~cs11.4.14-1
    • 8.7.0+ds+~cs27.17.17-1
    • 8.7.0+ds+~cs27.17.17-2
    • 8.7.0+ds+~cs27.17.17-2~bpo10+1
    • 8.7.0+ds+~cs27.17.17-3
    • 8.9.1+ds+~cs26.20.25-1
    • 8.9.3+ds+~cs29.13.19-1
    • 9.2.2+~2.0.0-1
    • 9.2.2+~2.0.0-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • mermaid npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 10.6.0, < 10.9.8

    Actualiza a 10.9.8

  • mermaid npm

    Intervalos de versiones afectados
    • SEMVER: ≥ 11.0.0-alpha.1, < 11.16.1

    Actualiza a 11.16.1

  • node-mermaid Ubuntu:22.04:LTS

    Versiones
    • 8.7.0+ds+~cs27.17.17-3
    • 8.13.3+ds+~cs26.13.21-1
    • 8.13.3+ds+~cs26.13.21-2
    • 8.13.8+~cs10.4.16-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

  • node-mermaid Ubuntu:26.10

    Versiones
    • 9.2.2+~2.0.0-1
    • 9.2.2+~2.0.0-2
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →