p PatchFirst

CVE-2026-73255

CVE-2026-73255 · Mongoose: Path traversal in SSI #include directives enables arbitrary file read

Esta página presenta datos de fuentes públicas de vulnerabilidades. Consulta el aviso original antes de actualizar.

Mongoose is an embedded web server and network library. Prior to 7.22, an attacker who can control an SSI-enabled file can place directory traversal sequences in an #include file or #include virtual directive. The mg_ssi() function in src/ssi.c concatenates the directive argument into a filesystem path without calling mg_path_is_sane(), allowing an MG_ENABLE_SSI deployment with ssi_pattern configured to disclose files readable by the Mongoose process. This issue is fixed in version 7.22.

CVSS 6.5 · Media · EPSS 0,7% · Corrección disponible

Publicación
Actualización

Pila tecnológica: system

Productos y versiones afectados

  • mongoose

    Versiones
    • < 7.22: Afectada

    Sin corrección publicada

  • mongoose Debian:14

    Versiones
    • 7.21+ds-1
    • 7.21+ds-1~bpo13+1
    • 7.21+ds-2
    • 7.22+ds-1~bpo13+1
    Intervalos de versiones afectados
    • ECOSYSTEM: < 7.22+ds-1

    Actualiza a 7.22+ds-1

  • mongoose Ubuntu:26.10

    Versiones
    • 7.21+ds-1
    • 7.21+ds-2
    • 7.22+ds-1
    • 7.23+ds-1
    Intervalos de versiones afectados
    • ECOSYSTEM: (−∞, +∞)

    Sin corrección publicada

Fuentes originales

Comprueba tu servidor →